Closed Bug 775229 Opened 8 years ago Closed 8 years ago

browser.urlbar.autoFill subtly auto-selects from suggestion list without clear indication of behavior

Categories

(Firefox :: Untriaged, defect)

14 Branch
x86
Windows Vista
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 769994

People

(Reporter: aufbeschissener_kunde, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.0; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

First of all, I think Firefox silently updated over night from 14.0.0 to 14.0.1, because Firefox updated to 14 yesterday or the day before, and then this never happened until today:  I Typed in a VERY MOST FREQUENTLY EVERY WORK-DAY used URL, without any protocol, along the lines of "dev.example.com" (not the actual website).

This is a website I have been developing for well over a year, so the vast majority of its uses on my machine are http://dev.example.com/some/file/location and rarely ever just http://dev.example.com.

I believe I was on a blank tab when I did this.


Actual results:

Firefox redirected me to https://dev.example.com, which I have not visited since a few MONTHS ago.  After retyping the URL a few times, I finally noticed that "https://dev.example.com" was the third item in the auto-complete suggestion list, and that instead of appearing as a purple link like the other items, it was black and bold.  (The caption "Switch to tab" was also present, probably because the current tab was now https://dev.example.com, what with me having attempted to retype dev.example.com a few times.)  The intended http://dev.example.com was the fourth item in the list.

Without any sort of highlighting (aside from the extremely subtly increased font weight) to indicate that https://dev.example.com was selected, it was automatically inserted when I pressed ENTER.  This should NOT have happened because A) I didn't to type "https://" into the address bar, and B) I neither clicked on "https://dev.example.com" nor arrowed down to highlight it.


Expected results:

Firefox should have browsed to http://dev.example.com, that is, with default HTTP protocol, and not HTTPS protocol.

Setting browser.urlbar.autoFill to false resolved this issue, but since browser.urlbar.autoFill has been around for a while already and this has never happened, I don't think "browser.urlbar.autoFill = true" is behaving the way it's supposed to.
Thank you for your Reports. It's a known/already tracked Issue.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 769994
You need to log in before you can comment on or make changes to this bug.