Closed Bug 775271 Opened 10 years ago Closed 3 years ago

java.lang.NullPointerException: at com.android.internal.policy.impl.PhoneWindow.preparePanel(PhoneWindow.java) on Meizu devices with ICS

Categories

(Firefox for Android Graveyard :: General, defect)

16 Branch
ARM
Android
defect
Not set
critical

Tracking

(firefox16 affected, firefox17 affected, firefox18 affected, firefox19 affected, firefox21 affected, firefox22 affected, firefox23 affected, firefox25 affected)

RESOLVED WORKSFORME
Tracking Status
firefox16 --- affected
firefox17 --- affected
firefox18 --- affected
firefox19 --- affected
firefox21 --- affected
firefox22 --- affected
firefox23 --- affected
firefox25 --- affected

People

(Reporter: scoobidiver, Unassigned)

Details

(Keywords: crash, regression, Whiteboard: [native-crash])

Crash Data

Attachments

(1 file)

It first appeared in 16.0a1/20120709. Here is the latest crash report: bp-0f5a630b-2739-40c2-a7ac-0b92b2120718.

java.lang.NullPointerException
	at com.android.internal.policy.impl.PhoneWindow.preparePanel(PhoneWindow.java:518)
	at com.android.internal.policy.impl.PhoneWindow.onKeyDownPanel(PhoneWindow.java:850)
	at com.android.internal.policy.impl.PhoneWindow.onKeyDown(PhoneWindow.java:1520)
	at com.android.internal.policy.impl.PhoneWindow$DecorView.dispatchKeyEvent(PhoneWindow.java:1912)
	at android.view.ViewRootImpl.deliverKeyEventPostIme(ViewRootImpl.java:3351)
	at android.view.ViewRootImpl.handleFinishedEvent(ViewRootImpl.java:3324)
	at android.view.ViewRootImpl.handleMessage(ViewRootImpl.java:2479)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:4587)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:784)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:551)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A+at+com.android.internal.policy.impl.PhoneWindow.preparePanel%28PhoneWindow.java%29
15.0b1 is also affected.
Version: Firefox 16 → Firefox 15
Summary: java.lang.NullPointerException: at com.android.internal.policy.impl.PhoneWindow.preparePanel(PhoneWindow.java) → java.lang.NullPointerException: at com.android.internal.policy.impl.PhoneWindow.preparePanel(PhoneWindow.java) on ICS
It's currently #5 top crasher in 15.0 with many dupes.
Whiteboard: [native-crash] → [native-crash][startupcrash]
Keywords: topcrash
It's now #11 in 15.0, but only #91 in 16.0b1.

It's similar to bug 761929.

The regression range might be:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1751d97cc9e4&tochange=b6fb3d9bd1b9
It doesn't seem to touch any part of our code.
Few options for this bug are:
1. Hardware Menu key press on tablets will cause a crash -- which I've fixed (and probably uplifted).
2. Something related to accessibility.

On ICS, we don't use the android's panel. But the crash is on Android's panel -- which is confusing me.
It's now #31 top crasher in 15.0 and #89 in 16.0b1.
Keywords: topcrash
User reports that every time they open the Settings window Firefox has this crash. Requested more info about what device they are using.

https://support.mozilla.org/en-US/questions/938684
Crash stats show it happens only with Meizu devices.
Summary: java.lang.NullPointerException: at com.android.internal.policy.impl.PhoneWindow.preparePanel(PhoneWindow.java) on ICS → java.lang.NullPointerException: at com.android.internal.policy.impl.PhoneWindow.preparePanel(PhoneWindow.java) on Meizu devices with ICS
Support for comment 7, see signature in :
https://crash-analysis.mozilla.com/rkaiser/2012-10-09/2012-10-09.fennecandroid.release.16.0.devices.html#sigs

java.lang.NullPointerException: at com.android.internal.policy.impl.PhoneWindow.preparePanel(PhoneWindow.java) 	12
Meizu M032 	11
Meizu M9        1
Version: Firefox 15 → Trunk
I've traced the source of the error to the file android.policy.odex.

After disassembling it I've noticed a missing null-Reference check in it, fixed it, reassembled it... and turned it into a update that every HK Meizu MX user can flash (given that he is on 1.1.5 FlyMe OS already).

Important: when flashing do NOT tick the checkbox stating "wipe data" !

This bug is FIXED - and can be closed as this problem is out of reach for the Mozilla team, but instead something Meizu has to address (or in this case, me).
(In reply to gentleman.trilby from comment #9)
> This bug is FIXED
Only if the update is automatic for every Meizu users on ICS. Is it?
Depends on what you mean by automatic.
The file I've attached installs just like a regular firmware update.

If you mean waiting for Meizu to do a official ota.. Good luck waiting for that.
Whiteboard: [native-crash][startupcrash] → [native-crash]
Version: Trunk → Firefox 16
Crash Signature: [@ java.lang.NullPointerException: at com.android.internal.policy.impl.PhoneWindow.preparePanel(PhoneWindow.java)] → [@ java.lang.NullPointerException: at com.android.internal.policy.impl.PhoneWindow.preparePanel(PhoneWindow.java)] [@ java.lang.NullPointerException: at com.android.internal.policy.impl.PhoneWindow.preparePanel]

Closing because no crashes reported for 12 weeks.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.