Closed Bug 775334 Opened 7 years ago Closed 7 years ago

Make about:home clean

Categories

(Firefox for Android :: Theme and Visual Design, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 17
Tracking Status
firefox15 --- verified
firefox16 --- verified
firefox17 --- verified
firefox18 --- verified

People

(Reporter: sriram, Unassigned)

Details

Attachments

(1 file)

Make about:home cleaner as per: http://cl.ly/image/2S2o1l3v3M1y/o
Attached patch PatchSplinter Review
This makes changes to about:home as mentioned in the specs.
Thumbnails will be done as a separate patch.
Attachment #643629 - Flags: review?(mark.finkle)
OS: Mac OS X → Android
Hardware: x86 → ARM
Comment on attachment 643629 [details] [diff] [review]
Patch

Looks OK
Attachment #643629 - Flags: review?(mark.finkle) → review+
Is this part of some tablet UI change? If not, we should not be working on it yet. If so, we should be setting the flags to get it tracked and uplifted.
http://hg.mozilla.org/integration/mozilla-inbound/rev/482d99267d48

This is just parts leading to tablet UI change. The about:home for tablets will be based on this.
https://hg.mozilla.org/mozilla-central/rev/482d99267d48
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 17
Comment on attachment 643629 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New UI.
User impact if declined: Better styling of about:home to make it tablet ready.
Testing completed (on m-c, etc.): Landed in m-c on 07/20
Risk to taking this patch (and alternatives if risky): None.
String or UUID changes made by this patch: None.
Attachment #643629 - Flags: approval-mozilla-beta?
Attachment #643629 - Flags: approval-mozilla-aurora?
Comment on attachment 643629 [details] [diff] [review]
Patch

[Triage Comment]
Approving for branches in support of tablet UI given the low risk evaluation.
Attachment #643629 - Flags: approval-mozilla-beta?
Attachment #643629 - Flags: approval-mozilla-beta+
Attachment #643629 - Flags: approval-mozilla-aurora?
Attachment #643629 - Flags: approval-mozilla-aurora+
Verifying everything but the thumbnail-screenshots in the mockup on mozilla-15 (beta 2, build #1)
Status: RESOLVED → VERIFIED
about:home looks cleaner on the latest Nightly, Aurora and Beta build. Setting flags to verified.

--
Device: Galaxy Note
OS: Android 4.0.4
You need to log in before you can comment on or make changes to this bug.