Cannot start drag in input tag

RESOLVED FIXED

Status

()

Core
Editor
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Luke, Unassigned)

Tracking

({regression})

13 Branch
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

Drag selected text from a input box.

This bug is both in firefox 13 and 14.


Actual results:

nothing


Expected results:

the text should of been dragged from the input box so it appeared under my cursor.
(Reporter)

Comment 1

5 years ago
This bug isnt in version 12, but I downgraded to 12.
Drag & Dropping the text from this bugzilla comment field works for me with Firefox13.0.1 and Seamonkey trunk
(Reporter)

Comment 3

5 years ago
Ok after further testing. I found that it happens on input tags with the "readonly" attribute.

Updated

5 years ago
Component: Untriaged → XUL
Product: Firefox → Core

Updated

5 years ago
Component: XUL → Drag and Drop
Triage is still not completed and i take care to move the bug to the right component.

Reporter: Do you have an example url that shows this issue ?
Component: Drag and Drop → Untriaged
Product: Core → Firefox
(Reporter)

Comment 5

5 years ago
You can recreate it yourself by going to:
http://w3schools.com/html/tryit.asp?filename=tryhtml_intro
and entering the following code in the left field:
<html><input readonly value='This text cant be dragged'></html>

Updated

5 years ago

Comment 6

5 years ago
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/a3b93f3949fe
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/20120217 Firefox/13.0a1 ID:20120217155649
Bad:
http://hg.mozilla.org/mozilla-central/rev/e001b5eda618
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/13.0a1 Firefox/13.0a1 ID:20120217162149
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a3b93f3949fe&tochange=e001b5eda618

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/174ce0df7cdd
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/13.0a1 Firefox/13.0a1 ID:20120217061753
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/51d333edddfd
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/13.0a1 Firefox/13.0a1 ID:20120217062249
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=174ce0df7cdd&tochange=51d333edddfd

Suspected: Bug 499008
Blocks: 499008
Status: UNCONFIRMED → NEW
tracking-firefox15: --- → ?
tracking-firefox16: --- → ?
tracking-firefox17: --- → ?
Component: Untriaged → Editor
Ever confirmed: true
Keywords: regression
Product: Firefox → Core

Comment 7

5 years ago
Sorry,

This seems to be fixed by Bug 612128 in Firefox15 and later.
Status: NEW → UNCONFIRMED
tracking-firefox15: ? → ---
tracking-firefox16: ? → ---
tracking-firefox17: ? → ---
Ever confirmed: false
(Reporter)

Comment 8

5 years ago
(In reply to Alice0775 White from comment #7)
> Sorry,
> 
> This seems to be fixed by Bug 612128 in Firefox15 and later.

Where can I get firefox 15? Is its beta available? I tried the latest nightly build and it still has the same problem.
You can download the latest beta from here: http://www.mozilla.org/en-US/firefox/beta/  It's currently the latest beta for Firefox 14, but Firefox 15 beta is being built and will be available within the next few days, and your build should automatically upgrade when Firefox 15 is available.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

5 years ago
Until 15 is available i will stay on 12, updates are disabled. Once 15 is available for download I will confirm it does fix this bug.
(Reporter)

Comment 11

5 years ago
Ok I downloaded firefox 15 beta and it is fixed.
You need to log in before you can comment on or make changes to this bug.