Pixelated compound SVG especially on background

RESOLVED DUPLICATE of bug 600207

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 600207
6 years ago
6 years ago

People

(Reporter: Lev Solntsev, Unassigned)

Tracking

17 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 3 obsolete attachments)

(Reporter)

Description

6 years ago
Created attachment 643800 [details]
test.svg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20120718030544

Steps to reproduce:

I'm trying to use SVG for sharp and scalable graphics. I've realized that one of the best methods would be using SVG sprites. However, 


Actual results:

Firefox scales SVG with reused parts (via <symbol> and <use>) on background like it's a bitmap image, thus getting it pixelated when zooming.


Expected results:

Clear and sharp images. SVG images should be correctly rendered when page is zoomed without pixelated bluriness.
(Reporter)

Comment 1

6 years ago
Created attachment 643801 [details]
A testcase

An HTML page with different ways of using SVG.
(Reporter)

Comment 2

6 years ago
Created attachment 643802 [details]
Screenshots of the testcase in Firefox in different zoom levels
(Reporter)

Comment 3

6 years ago
Created attachment 643803 [details]
A testcase

A HTML page with different ways of using SVG images.
Attachment #643801 - Attachment is obsolete: true
(Reporter)

Comment 4

6 years ago
Created attachment 643806 [details]
A testcase

I don't know why, but it seems that autodetection for the HTML doesn't work.
Attachment #643803 - Attachment is obsolete: true
(Reporter)

Comment 5

6 years ago
Created attachment 643807 [details]
A testcase

Last try
Attachment #643806 - Attachment is obsolete: true
(Reporter)

Comment 6

6 years ago
It could be related in some way to https://bugzilla.mozilla.org/show_bug.cgi?id=600207

Updated

6 years ago
Attachment #643807 - Attachment mime type: text/plain → text/html

Updated

6 years ago
Component: Untriaged → SVG
Product: Firefox → Core
Yeah, this is a duplicate of bug 600207.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
No longer depends on: 600207
Resolution: --- → DUPLICATE
Duplicate of bug: 600207
You need to log in before you can comment on or make changes to this bug.