Closed Bug 775507 Opened 9 years ago Closed 9 years ago

Self-serve's 'trigger dep builds' not working

Categories

(Release Engineering :: General, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: emorley, Assigned: catlee)

References

Details

(Keywords: buildapi)

Attachments

(1 file)

fx-team tip (https://hg.mozilla.org/integration/fx-team/rev/7b3b0c5c9933) was busted due to infra issues.

I tried to retrigger across all platforms using:
https://secure.pub.build.mozilla.org/buildapi/self-serve/fx-team/rev/7b3b0c5c9933

and entering '7b3b0c5c9933' under 'Create new dep builds on fx-team revision'.

First submitted a few hours ago and still no builds; tried again maybe 10-15 mins ago and nothing appearing either.
Blocks: 775545
I've triggered this manually for now.
Summary: Self-serve's 'trigger dep builds' not working on fx-team → Self-serve's 'trigger dep builds' not working
Assignee: nobody → catlee
Priority: -- → P2
Whiteboard: [selfserve]
the problem is that repo_path used to be a relative path to http://hg.mozilla.org, e.g. "integration/fx-team". With the change to use production-branches.json this got changed to "http://hg.m.o/integration/fx-team".

this patch gets the path out of the repo link with urlparse and uses that for hte buildbot sendchange.
Attachment #643877 - Flags: review?(rail)
Attachment #643877 - Flags: review?(rail) → review+
Attachment #643877 - Flags: checked-in+
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Thank you :-D
Keywords: buildapi
Whiteboard: [selfserve]
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.