can't extend xul:deck in XBL

VERIFIED INVALID

Status

()

Core
XBL
VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: David Hyatt)

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

can't extend xul:deck in XBL.

mozilla/mailnews/base/resources/content/mailWidgets.xml contains some XBL that
attempts to extend the xul:deck widget.  this worked at one point, but regressed.

the current behaviour is that all the "cards" in the deck are shown at once,
side by side.  see bug #71891
thanks to hyatt for offering to investigate this bad boy.

it would get our search and filter dialogs looking good again.
Blocks: 71891
Summary: can't extend xul:deck in XBL → can't extend xul:deck in XBL
No longer blocks: 71891
(Assignee)

Comment 2

17 years ago
This is not a bug.  You just need to use the display type now.

instead of

<myFoo>

with

<binding id="myFoo" extends="xul:deck">

and 

myFoo {
  -moz-binding: etc.
}

you should have

<binding id="myFoo">

myFoo {
  display: -moz-xul-deck;
  -moz-binding: etc.
}
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
thanks hyatt, testing that now.

is extends="" obsolete?
verified, hyatt's way is working.
No longer blocks: 71891
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.