Last Comment Bug 775647 - rm PND_INITIALIZED
: rm PND_INITIALIZED
Status: RESOLVED FIXED
[js:t]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla17
Assigned To: Luke Wagner [:luke]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-19 10:45 PDT by Luke Wagner [:luke]
Modified: 2012-07-24 03:01 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
preparation: tidy BindVarOrConst (3.33 KB, patch)
2012-07-19 10:46 PDT, Luke Wagner [:luke]
ejpbruel: review+
Details | Diff | Review
rm PND_INITIALIZED (14.71 KB, patch)
2012-07-19 10:47 PDT, Luke Wagner [:luke]
ejpbruel: review+
Details | Diff | Review

Description Luke Wagner [:luke] 2012-07-19 10:45:45 PDT
PND_INITIALIZED is now almost entirely unused.  The one use (commented in the patch) really just wants to know whether we are initializing a const vs. assigning to it (bad).  Removing this removes several confusing blobs from the Parser.
Comment 1 Luke Wagner [:luke] 2012-07-19 10:46:53 PDT
Created attachment 643920 [details] [diff] [review]
preparation: tidy BindVarOrConst

This is a trivial patch to merge branches in BindVarOrConst.
Comment 2 Luke Wagner [:luke] 2012-07-19 10:47:13 PDT
Created attachment 643921 [details] [diff] [review]
rm PND_INITIALIZED
Comment 3 Luke Wagner [:luke] 2012-07-19 13:46:01 PDT
Comment on attachment 643920 [details] [diff] [review]
preparation: tidy BindVarOrConst

Actually, ejpbruel has been getting into all this recently and volunteered himself for review.
Comment 4 Eddy Bruel [:ejpbruel] 2012-07-19 14:05:42 PDT
Comment on attachment 643920 [details] [diff] [review]
preparation: tidy BindVarOrConst

Review of attachment 643920 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good to me. If the call to addHoist is never reached, are we getting rid of it as well?
Comment 5 Eddy Bruel [:ejpbruel] 2012-07-19 14:30:54 PDT
Comment on attachment 643921 [details] [diff] [review]
rm PND_INITIALIZED

Review of attachment 643921 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me. You might also want to remove the reference to the term 'fresh' on line 2264, since it no longer has any meaning after this patch.

Note You need to log in before you can comment on or make changes to this bug.