Last Comment Bug 775653 - [AccessFu] Refactor traversal rules
: [AccessFu] Refactor traversal rules
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: mozilla17
Assigned To: Eitan Isaacson [:eeejay]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-19 10:52 PDT by Eitan Isaacson [:eeejay]
Modified: 2012-07-20 21:05 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Refactor traversal rules. (17.00 KB, patch)
2012-07-19 10:53 PDT, Eitan Isaacson [:eeejay]
dbolter: review+
Details | Diff | Review

Description Eitan Isaacson [:eeejay] 2012-07-19 10:52:15 PDT
There seems to be a lot of redundancy in our traversal rules, and they could probably be consolidated to one base rule with constructor arguments.
Comment 1 Eitan Isaacson [:eeejay] 2012-07-19 10:53:35 PDT
Created attachment 643928 [details] [diff] [review]
Refactor traversal rules.
Comment 2 David Bolter [:davidb] 2012-07-19 11:19:14 PDT
Comment on attachment 643928 [details] [diff] [review]
Refactor traversal rules.

Review of attachment 643928 [details] [diff] [review]:
-----------------------------------------------------------------

Much improved.
Comment 3 Marco Zehe (:MarcoZ) 2012-07-20 01:50:00 PDT
Yeah, very nice!
Comment 4 Eitan Isaacson [:eeejay] 2012-07-20 09:49:12 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/d1582dade09a
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-07-20 21:05:28 PDT
https://hg.mozilla.org/mozilla-central/rev/d1582dade09a

Note You need to log in before you can comment on or make changes to this bug.