Last Comment Bug 775692 - Rename rule.inheritedSource
: Rename rule.inheritedSource
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Inspector (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: Firefox 17
Assigned To: Heather Arthur [:harth]
: developer.tools
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-19 12:20 PDT by Paul Rouget [:paul]
Modified: 2012-07-21 03:51 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
rename string (1.69 KB, patch)
2012-07-19 14:38 PDT, Heather Arthur [:harth]
paul: review+
Details | Diff | Review

Description Paul Rouget [:paul] 2012-07-19 12:20:06 PDT
As per comment: bug 712469 comment 73, we should rename rule.inheritedSource because its content has changed.

(In reply to Francesco Lodolo [:flod] from bug 712469 comment #73)
> -# e.g "Inherited from body#bodyID (styles.css:20)"
> -rule.inheritedSource=Inherited from %S (%S)
> +# e.g "Inherited from body#bodyID"
> +rule.inheritedSource=Inherited from %S
> 
> I know I should probably open a new bug for this, but:
> 
> a) don't change a string like this (removing a variable) without changing
> its name as well
> b) you should update its l10n comment (last line)
> 
> # LOCALIZATION NOTE (rule.inheritedSource): Shown for CSS rules
> # that were inherited from a parent node.  Will be passed a node
> # identifier and a source location.
Comment 1 Heather Arthur [:harth] 2012-07-19 14:38:33 PDT
Created attachment 644019 [details] [diff] [review]
rename string

rename to "rule.inheritedFrom"
Comment 2 Paul Rouget [:paul] 2012-07-19 15:09:10 PDT
Comment on attachment 644019 [details] [diff] [review]
rename string

r+

You didn't have to change the name. You could have changed it to rule.inheritedSource2.

Up to you.
Comment 3 Heather Arthur [:harth] 2012-07-20 08:00:29 PDT
https://hg.mozilla.org/integration/fx-team/rev/1b756e58e59a
Comment 4 Tim Taubert [:ttaubert] 2012-07-21 03:51:48 PDT
https://hg.mozilla.org/mozilla-central/rev/1b756e58e59a

Note You need to log in before you can comment on or make changes to this bug.