-moz-transform : skew("degree") not working in 14.0.1 and verified it is working in 13.0.1

RESOLVED DUPLICATE of bug 747637

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 747637
6 years ago
6 years ago

People

(Reporter: tommys212, Unassigned)

Tracking

13 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

-moz-trasnform : skew("degree") not working in 14.0.1 and verified it is working in 13.0.1


Actual results:

It doesnt trasnform but downgraded back to 13 and it works again


Expected results:

It should of transformed to that degree posted

Comment 1

6 years ago
Hi Tommy, I would also like to note that you have a typo, can you verify this typo isn't present in the actual document?

-moz-trasnform : skew("degree") -> should be -> -moz-transform : skew("degree")

*s and n are swapped

Comment 2

6 years ago
The Live Example is also working for me with Firefox 14.0.1

https://developer.mozilla.org/en/CSS/-moz-transform#section_5
(Reporter)

Comment 3

6 years ago
-moz-transform : skew(-11deg);

that is my code it isnt working on 14.0.1 but working on 13.

No code is changed between changing versions.

But your example works!?!?
(Reporter)

Comment 4

6 years ago
Have to use the following

-moz-transform: skewX(-11deg);

skew no longer works you have to define the skew parameter X or Y

Comment 5

6 years ago
Ah, I see. The live example I linked to is using a different transform.

The skew transform was removed from Firefox 14 because it was only experimental. The W3C (World Wide Web Consortium) has eliminated this from the CSS3 specification, so this the appropriate thing to do would be to remove this from Firefox (which you can see has been done).

https://developer.mozilla.org/en/CSS/transform#section_14

I don't know if there is a replacement, but I bet you can achieve the same result with a combination of degree and perspective transforms.

Comment 6

6 years ago
I apologize, I missed something again. It appears only the shorthand property of skew is removed. As you've already seen, skewX and skewY still work.
(Reporter)

Comment 7

6 years ago
Yes thanks just a quick find and replace in my code.

Thanks again.

Comment 8

6 years ago
See bug 734953.
Blocks: 734953
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
We've decided we're going to restore skew() support.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 747637
Summary: -moz-trasnform : skew("degree") not working in 14.0.1 and verified it is working in 13.0.1 → -moz-transform : skew("degree") not working in 14.0.1 and verified it is working in 13.0.1
You need to log in before you can comment on or make changes to this bug.