Last Comment Bug 775788 - Reflow JSFunctionSpec to accept JSJitInfos
: Reflow JSFunctionSpec to accept JSJitInfos
Status: RESOLVED FIXED
[js:t]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla17
Assigned To: Eric Faust [:efaust]
:
Mentors:
Depends on:
Blocks: 747290
  Show dependency treegraph
 
Reported: 2012-07-19 17:10 PDT by Eric Faust [:efaust]
Modified: 2012-08-08 09:28 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (14.64 KB, patch)
2012-07-19 17:18 PDT, Eric Faust [:efaust]
luke: review+
Details | Diff | Review

Description Eric Faust [:efaust] 2012-07-19 17:10:55 PDT
Similar to bug 766448, method calls for the new bindings (bug 747290) require JSJitInfo feed-through.
Comment 1 Eric Faust [:efaust] 2012-07-19 17:18:21 PDT
Created attachment 644078 [details] [diff] [review]
Patch

Applies on top of patch in bug 766448
Comment 2 Luke Wagner [:luke] 2012-07-20 03:23:26 PDT
Comment on attachment 644078 [details] [diff] [review]
Patch

Looks good.  If you haven't already, I'd be sure to try (on all platforms, since iirc, there is some windows-only JSAPI use...).
Comment 4 Ed Morley [:emorley] 2012-08-08 09:28:26 PDT
https://hg.mozilla.org/mozilla-central/rev/de8febc86738

Note You need to log in before you can comment on or make changes to this bug.