LambdaIsGetElem should look for JSOP_GETALIASEDVAR

RESOLVED FIXED in mozilla17

Status

()

Core
JavaScript Engine
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: luke, Assigned: luke)

Tracking

unspecified
mozilla17
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [js:p1])

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

5 years ago
Created attachment 644102 [details] [diff] [review]
fix

After bug 753158, LambdaIsGetElem should sniff JSOP_GETALIASEDVAR instead of JSOP_NAME.  This fixes a 10ms regression on sunspider unpack-code after bug 753158.
Attachment #644102 - Flags: review?(dvander)
(Assignee)

Comment 1

5 years ago
Created attachment 644109 [details] [diff] [review]
qref'd

oops
Attachment #644102 - Attachment is obsolete: true
Attachment #644102 - Flags: review?(dvander)
Attachment #644109 - Flags: review?(dvander)
Attachment #644109 - Flags: review?(dvander) → review+
(Assignee)

Comment 2

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/970b733bd01d
Target Milestone: --- → mozilla17
Whiteboard: [js:t]
Whiteboard: [js:t] → [js:p1]
(Assignee)

Comment 3

5 years ago
and backed out b/c of some bustage on talos...
https://hg.mozilla.org/integration/mozilla-inbound/rev/10d1f5a84f4e
Target Milestone: mozilla17 → ---
(Assignee)

Comment 4

5 years ago
Hah, there was a pre-existing (but less likely to be exercised, due to the use of dynamic name lookup) bug where we did upvar lookup in the current scope instead of the lambda's environment.  D'oh.
(Assignee)

Comment 5

5 years ago
Pushed with shell testcase:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f4e588e1b681
(Assignee)

Updated

5 years ago
Target Milestone: --- → mozilla17
https://hg.mozilla.org/mozilla-central/rev/f4e588e1b681
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.