Last Comment Bug 775844 - Need to include constructor signature types when we make up our lists of types to examine
: Need to include constructor signature types when we make up our lists of type...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla17
Assigned To: Boris Zbarsky [:bz] (TPAC)
:
Mentors:
Depends on:
Blocks: ParisBindings 777066
  Show dependency treegraph
 
Reported: 2012-07-19 21:25 PDT by Boris Zbarsky [:bz] (TPAC)
Modified: 2012-07-27 08:14 PDT (History)
3 users (show)
bzbarsky: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Make sure to examine constructor signatures when looking for union types. (9.16 KB, patch)
2012-07-19 21:33 PDT, Boris Zbarsky [:bz] (TPAC)
no flags Details | Diff | Splinter Review
Make sure to examine constructor signatures when looking for union types. (9.83 KB, patch)
2012-07-20 00:55 PDT, Boris Zbarsky [:bz] (TPAC)
no flags Details | Diff | Splinter Review
Make sure to examine constructor signatures when looking for union types. (9.97 KB, patch)
2012-07-20 08:08 PDT, Boris Zbarsky [:bz] (TPAC)
khuey: review+
Details | Diff | Splinter Review

Description Boris Zbarsky [:bz] (TPAC) 2012-07-19 21:25:09 PDT
Otherwise, for example, using a union type in a constructor argument doesn't actually pick it up as a type to generate union stuff for.
Comment 1 Boris Zbarsky [:bz] (TPAC) 2012-07-19 21:33:09 PDT
Created attachment 644173 [details] [diff] [review]
Make sure to examine constructor signatures when looking for union types.

Also includes some distinguishability fixes
Comment 2 Boris Zbarsky [:bz] (TPAC) 2012-07-20 00:55:56 PDT
Created attachment 644214 [details] [diff] [review]
Make sure to examine constructor signatures when looking for union types.
Comment 3 Boris Zbarsky [:bz] (TPAC) 2012-07-20 08:08:28 PDT
Created attachment 644345 [details] [diff] [review]
Make sure to examine constructor signatures when looking for union types.
Comment 4 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-07-26 15:29:57 PDT
Why are the tests commented out?
Comment 5 Boris Zbarsky [:bz] (TPAC) 2012-07-26 18:14:22 PDT
Because union codegen dumps all the unions in a single header file and that file is included from all bindings that use unions.  So if I uncomment that, the header file ends up with TestInterface* and whatnot in it and real (non-test) bindings that use unions can't find the test headers and fail to build.

I can add a comment to that effect to the test webidl if desired.
Comment 6 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-07-26 18:36:17 PDT
Comment on attachment 644345 [details] [diff] [review]
Make sure to examine constructor signatures when looking for union types.

Review of attachment 644345 [details] [diff] [review]:
-----------------------------------------------------------------

Ok.
Comment 7 Boris Zbarsky [:bz] (TPAC) 2012-07-26 21:10:16 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/3a7ac28c4ca9
Comment 8 Ed Morley [:emorley] 2012-07-27 08:14:47 PDT
https://hg.mozilla.org/mozilla-central/rev/3a7ac28c4ca9

Note You need to log in before you can comment on or make changes to this bug.