"@foo@.in: WARNING: no preprocessor directives found" when running Preprocessor unit test

RESOLVED FIXED in mozilla17

Status

()

Core
Build Config
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

unspecified
mozilla17
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Comment hidden (empty)
Created attachment 644376 [details] [diff] [review]
Avoid warning when running unit-Preprocessor.py
Attachment #644376 - Flags: review?(ted.mielczarek)
Assignee: nobody → mh+mozilla
Comment on attachment 644376 [details] [diff] [review]
Avoid warning when running unit-Preprocessor.py

Review of attachment 644376 [details] [diff] [review]:
-----------------------------------------------------------------

This is fine, but why do we warn in this case? We are doing a substitution, just not using preprocessor directives. That seems like a valid use of Preprocessor.py.
Attachment #644376 - Flags: review?(ted.mielczarek) → review+
Created attachment 645375 [details] [diff] [review]
Avoid Preprocessor.py warning when no commands are processed, but filters are
Attachment #645375 - Flags: review?(ted.mielczarek)
Attachment #644376 - Attachment is obsolete: true
Attachment #645375 - Flags: review?(ted.mielczarek) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/e4e68cf2bd40
Target Milestone: --- → mozilla17

Comment 5

5 years ago
Push backed out for Windows mochitest crashes:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=eecd3aa199e6

https://hg.mozilla.org/integration/mozilla-inbound/rev/1abfd50c8be6
Relanded, as it was innocent
https://hg.mozilla.org/integration/mozilla-inbound/rev/e0a8b539d562

Comment 7

5 years ago
https://hg.mozilla.org/mozilla-central/rev/e0a8b539d562
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.