Scrolling inconsistent in Reader Mode

RESOLVED DUPLICATE of bug 778488

Status

()

Firefox for Android
Reader View
RESOLVED DUPLICATE of bug 778488
6 years ago
6 years ago

People

(Reporter: mcomella, Unassigned)

Tracking

17 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox17 affected)

Details

1) Open Firefox 17.
2) Go to http://www.squishable.com/pc/squish_upright_penguin_15/fp_squishables/Squishable+Penguin
3) Click the Reader Mode button.
4) Scroll around the page.

Expected: Scrolling works just like any other page
Actual: Scrolling sometimes gets stuck and you are unable to move the screen unless you wait.

Scrolling down and throwing the page up to the top with a bounce and then rapidly trying to scroll down seems to repo this the easiest. It was easier to repo this on my phone than on my tablet.

Different pages seem to have different problems from others. Scrolling stops working often on the first set of images on this page: http://www.stuckincustoms.com/hdr-tutorial/

Generally, scrolling down stops it more often than scrolling up. Also, if the page is already in motion, it rarely gets stuck. It's more often when you stop the momentum yourself and then try to rescroll.

Tested on Galaxy Nexus, Android 4.0.4, and Asus Transformer Prime, Android 4.0.3.
Could the pages have iframes? Sometimes we get stuck or act strangely when tapping/panning in an iframe.
When I've experienced the scrolling issues, I have not been scrolling on iframes directly.

The first page has iframes on the original page for social features (Facebook/Twitter). This content does not seem to appear in the reader page (I can't figure out how to view reader source, if it's possible, so I don't know for sure).

The second page has an iframe embeded in the original page's content as a Youtube video in addition to the same social buttons – both do not appear in the reader content (although the Youtube video probably should – perhaps a bug?).

I'll try to do some more testing to see if this is directly related.
Scrolling on Mobile Wikipedia in Reader mode, which has no iframes, can get stuck. (Example page: http://en.m.wikipedia.org/wiki/United_states) In contrast, the regular mobile page (with images and all) tends to scroll smoothly.

Again, it is easier to repo this while scrolling down and while scrolling rapidly (using many gestures). Images tend to cause problems.

I have not yet been able to repo using my own test pages.
(In reply to Michael Comella (:mcomella) from comment #3)
> Images tend to cause problems.

By this I meant that trying to scroll directly on an image while the page is not moving will generally have no effect – the page will not scroll.

Trying to scroll directly on the image in this page's Reader mode is another good example: https://www.nytimes.com/2012/07/24/sports/ncaafootball/penn-state-penalties-include-60-million-fine-and-bowl-ban.html?_r=2&hp

It is an easy tablet repo case too.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 778488
You need to log in before you can comment on or make changes to this bug.