Last Comment Bug 776109 - ###!!! ABORT: failed to construct LayersChild: file /data/jenkins/jobs/b2g-build/workspace/widget/xpwidgets/nsBaseWidget.cpp, line 901 in B2G emulator with software rendering
: ###!!! ABORT: failed to construct LayersChild: file /data/jenkins/jobs/b2g-bu...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget (show other bugs)
: Trunk
: ARM All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-20 14:20 PDT by Jonathan Griffin (:jgriffin)
Modified: 2012-08-15 15:15 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Jonathan Griffin (:jgriffin) 2012-07-20 14:20:42 PDT
The Amazon EC2 VMs we use for B2G continuous integration do not have GPU's; the emulator always runs in software rendering mode, even with -gpu on.  In this environment, gecko crashes on startup with the following:

I/Gecko   (  104): Logging GL tracing output to /system/b2g/firefox.trace
I/Gecko   (  104): Attempting load of /data/local/egltrace.so
I/Gecko   (  104): Attempting load of libEGL.so
D/libEGL  (  104): Emulator without GPU support detected. Fallback to software renderer.
D/libEGL  (  104): loaded /system/lib/egl/libGLES_android.so
I/Gecko   (  104): Failed to create EGL config!
I/Gecko   (  104): ###!!! ABORT: failed to construct LayersChild: file /data/jenkins/jobs/b2g-build/workspace/widget/xpwidgets/nsBaseWidget.cpp, line 901
F/libc    (  104): Fatal signal 11 (SIGSEGV) at 0x00000000 (code=1)
I/DEBUG   (  103): debuggerd committing suicide to free the zombie!

This is blocking us from running any tests in CI atm.
Comment 1 Dietrich Ayala (:dietrich) 2012-07-24 13:49:16 PDT
Geo said that we must have this in order to run tests that require the emulator environment to be configured, for things like setting and testing battery level.

Can you comment as to whether this is a requirement for CI?
Comment 2 Jonathan Griffin (:jgriffin) 2012-07-24 13:55:31 PDT
(In reply to Dietrich Ayala (:dietrich) from comment #1)
> Geo said that we must have this in order to run tests that require the
> emulator environment to be configured, for things like setting and testing
> battery level.
> 
> Can you comment as to whether this is a requirement for CI?

Yes, this is a requirement for CI.  mwu is currently looking into how to support this.
Comment 3 Dietrich Ayala (:dietrich) 2012-07-29 23:17:13 PDT
Assigning to mwu per comment #2.
Comment 4 Jonathan Griffin (:jgriffin) 2012-07-30 09:38:44 PDT
Mwu has identified a new VM configuration that we can use for CI; we are transitioning to these, see bug 778260.  This issue thus no longer blocks CI.
Comment 5 Jonathan Griffin (:jgriffin) 2012-08-15 15:15:45 PDT
This problem was due to the fact that the emulator started requiring some GL libs in /out/host/linux-x86/lib, which we weren't packaging.  We are packaging them now, and this problem no longer occurs.

Note You need to log in before you can comment on or make changes to this bug.