Last Comment Bug 776249 - Images and pages not fully loaded, web console reports "Image corrupt or truncated"
: Images and pages not fully loaded, web console reports "Image corrupt or trun...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks: 767779
  Show dependency treegraph
 
Reported: 2012-07-21 08:08 PDT by Francesco Lodolo [:flod]
Modified: 2012-07-23 04:17 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Example (apple.com/mac) (144.95 KB, image/jpeg)
2012-07-21 08:16 PDT, Francesco Lodolo [:flod]
no flags Details

Description Francesco Lodolo [:flod] 2012-07-21 08:08:49 PDT
I'm running Nightly on a brand new MacBook Pro (10.7.4) and very often pages are not fully displayed (I see half images and sometimes even mangled layouts). A new profile shows the same issue.

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:17.0) Gecko/17.0 Firefox/17.0

At first I thought it was a problem with hardware acceleration, but disabling it didn't solve the problem. Then I realized that shift+reload fixes the problem and there are several loading errors in webconsole, so maybe it's cache related.

I can exclude network problems (other Macs and PCs on the same network work fine), Safari on the same Mac loads pages without problems. 

Not sure if it matters but this system uses an after-market SSD disk (SanDisk Extreme) with Trim enabled.
Comment 1 Francesco Lodolo [:flod] 2012-07-21 08:16:17 PDT
Created attachment 644643 [details]
Example (apple.com/mac)

This is an example (see header images). cmd+R doesn't fix the problem, cmr+shift+R does
Comment 2 Tim Taubert [:ttaubert] 2012-07-21 09:19:27 PDT
Probably caused by bug 767779 if it started with today's Nightly. We backed it out and re-built. Can you please check for updates manually and report back?
Comment 3 Francesco Lodolo [:flod] 2012-07-22 05:15:24 PDT
I've been using the updated version for several minutes and it works fine (with the previous version I couldn't browse 10 seconds without seeing broken images).

I'll let you close this bug because I never know the proper status for this kind of situations ;-)
Comment 4 Tim Taubert [:ttaubert] 2012-07-23 04:17:53 PDT
Bug 767779 was backed out.

Note You need to log in before you can comment on or make changes to this bug.