The default bug view has changed. See this FAQ.

java.lang.NullPointerException: at org.mozilla.gecko.AboutHomeContent.onInterceptTouchEvent(AboutHomeContent.java)

RESOLVED FIXED in Firefox 15

Status

()

Firefox for Android
General
--
critical
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: Scoobidiver (away), Assigned: mbrubeck)

Tracking

({crash, regression, topcrash})

17 Branch
Firefox 17
ARM
Android
crash, regression, topcrash
Points:
---

Firefox Tracking Flags

(firefox15 fixed, firefox16 fixed)

Details

(Whiteboard: [native-crash], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
There are two crashes from the same user in 17.0a1/20120721, including bp-7e617e15-6274-457c-8aaa-6d22e2120721.

java.lang.NullPointerException
	at org.mozilla.gecko.AboutHomeContent.onInterceptTouchEvent(AboutHomeContent.java:360)
	at android.view.ViewGroup.dispatchTouchEvent(ViewGroup.java:940)
	at android.view.ViewGroup.dispatchTouchEvent(ViewGroup.java:961)
	at android.view.ViewGroup.dispatchTouchEvent(ViewGroup.java:961)
	at android.view.ViewGroup.dispatchTouchEvent(ViewGroup.java:961)
	at android.view.ViewGroup.dispatchTouchEvent(ViewGroup.java:961)
	at android.view.ViewGroup.dispatchTouchEvent(ViewGroup.java:961)
	at com.android.internal.policy.impl.PhoneWindow$DecorView.superDispatchTouchEvent(PhoneWindow.java:1691)
	at com.android.internal.policy.impl.PhoneWindow.superDispatchTouchEvent(PhoneWindow.java:1125)
	at android.app.Activity.dispatchTouchEvent(Activity.java:2096)
	at com.android.internal.policy.impl.PhoneWindow$DecorView.dispatchTouchEvent(PhoneWindow.java:1675)
	at android.view.ViewRoot.deliverPointerEvent(ViewRoot.java:2219)
	at android.view.ViewRoot.handleMessage(ViewRoot.java:1903)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:138)
	at android.app.ActivityThread.main(ActivityThread.java:3701)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:507)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:878)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:636)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A+at+org.mozilla.gecko.AboutHomeContent.onInterceptTouchEvent%28AboutHomeContent.java%29
(Reporter)

Comment 1

5 years ago
It has been hit by 3 users in the same build. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3a05d298599e&tochange=446b788ab99d
It's likely a regression from bug 766858.
Blocks: 766858
Keywords: regression
Version: Trunk → Firefox 17
(Reporter)

Updated

5 years ago
tracking-fennec: --- → ?
Keywords: topcrash
(Assignee)

Updated

5 years ago
Assignee: nobody → mbrubeck
(Assignee)

Comment 2

5 years ago
Created attachment 644985 [details] [diff] [review]
patch

I'm not sure exactly how this crash can be reproduced, but this null check should fix it and is a good idea for safety anyway.
Attachment #644985 - Flags: review?(bugmail.mozilla)
Attachment #644985 - Flags: review?(bugmail.mozilla) → review+
(Assignee)

Comment 3

5 years ago
Comment on attachment 644985 [details] [diff] [review]
patch

https://hg.mozilla.org/integration/mozilla-inbound/rev/8ebc191e23eb

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 766858

User impact if declined: crashes

Testing completed (on m-c, etc.): Landed on inbound 7/23.

Risk to taking this patch (and alternatives if risky): No-risk Android-only fix (just adds two null checks).

String or UUID changes made by this patch: None.
Attachment #644985 - Flags: checkin+
Attachment #644985 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

5 years ago
Attachment #644985 - Flags: approval-mozilla-beta?
Comment on attachment 644985 [details] [diff] [review]
patch

no risk, android-only, and needed for bug 766858 - approving.
Attachment #644985 - Flags: approval-mozilla-beta?
Attachment #644985 - Flags: approval-mozilla-beta+
Attachment #644985 - Flags: approval-mozilla-aurora?
Attachment #644985 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/90c5090a3523
https://hg.mozilla.org/releases/mozilla-beta/rev/1eb1fcefd5ae
status-firefox15: --- → fixed
status-firefox16: --- → fixed
Target Milestone: --- → Firefox 17
https://hg.mozilla.org/mozilla-central/rev/8ebc191e23eb
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.