Keyboard Shortcut Ctrl+Shift+J (Open Error Console) does not work in 21 July Nightly build

RESOLVED FIXED in Firefox 17

Status

()

Firefox
General
RESOLVED FIXED
5 years ago
13 days ago

People

(Reporter: Alice0775 White, Assigned: paul)

Tracking

({regression})

17 Branch
Firefox 17
x86
All
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed-in-fx-team])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/446b788ab99d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120721041038

Keyboard Shortcut Ctrl+Shift+J (Open Error Console) does not work in Windows build(It works in Ubuntu).

Updated

5 years ago
Assignee: nobody → paul

Comment 1

5 years ago
The "works in Ubuntu" was my report, but after that I updated to the current build and the key combination doesn't work. (Several other key combinations work.)
OS: Windows 7 → All
Summary: Keyboard Shortcut Ctrl+Shift+J (Open Error Console) does not work in Windows build → Keyboard Shortcut Ctrl+Shift+J (Open Error Console) does not work in 21 July Nightly build
intended ? https://bugzilla.mozilla.org/show_bug.cgi?id=765564#c27

Comment 3

5 years ago
(In reply to Jim Jeffery not reading bug-mail 1/2/11 from comment #2)
> intended ? https://bugzilla.mozilla.org/show_bug.cgi?id=765564#c27

If it was intended it was a sloppy removal. I created a new profile and installed keyconfig and Error Console is still listed as being bound to Ctrl+Shift+J. Also, the Firefox menu entry for Error Console still lists Ctrl+Shift+J as the binding.
(Assignee)

Comment 4

5 years ago
(working on it)
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 5

5 years ago
Created attachment 644957 [details] [diff] [review]
v1
(Assignee)

Updated

5 years ago
Attachment #644957 - Flags: review?(dao)
Comment on attachment 644957 [details] [diff] [review]
v1

This looks like the key combo would always open the console regardless of the broadcaster's state.
Attachment #644957 - Flags: review?(dao) → review-
(Assignee)

Comment 7

5 years ago
Right. And we have this problem with all the tools.
(Assignee)

Comment 8

5 years ago
Created attachment 645017 [details] [diff] [review]
v1.1
(Assignee)

Updated

5 years ago
Attachment #644957 - Attachment is obsolete: true
(Assignee)

Comment 9

5 years ago
Comment on attachment 645017 [details] [diff] [review]
v1.1

Rob, can you take a look at this before I go through the browser review again?
Attachment #645017 - Flags: feedback?(rcampbell)
Comment on attachment 645017 [details] [diff] [review]
v1.1

diff --git a/browser/base/content/browser.js b/browser/base/content/browser.js

In the section enabling tools for each pref, you might use a Map of pref name to element id and iterate through those to do the removeAttribute("disabled"|"hidden") bits. Will cut down on a bit of the patch size.

Otherwise, this looks fine.
Attachment #645017 - Flags: feedback?(rcampbell) → feedback+
(Assignee)

Comment 11

5 years ago
(In reply to Rob Campbell [:rc] (:robcee) from comment #10)
> Comment on attachment 645017 [details] [diff] [review]
> v1.1
> 
> diff --git a/browser/base/content/browser.js
> b/browser/base/content/browser.js
> 
> In the section enabling tools for each pref, you might use a Map of pref
> name to element id and iterate through those to do the
> removeAttribute("disabled"|"hidden") bits. Will cut down on a bit of the
> patch size.

I will do that in a followup bug (or in the future devtools.jsm file).
(Assignee)

Updated

5 years ago
Attachment #645017 - Flags: review?(dao)

Updated

5 years ago
Attachment #645017 - Flags: review?(dao) → review+
(Assignee)

Comment 12

5 years ago
https://tbpl.mozilla.org/?tree=Try&rev=c77e9ebe89bb
(Assignee)

Comment 13

5 years ago
https://hg.mozilla.org/integration/fx-team/rev/a4ce9e1d4135
Whiteboard: [fixed-in-fx-team]
(Assignee)

Comment 14

5 years ago
https://hg.mozilla.org/mozilla-central/rev/a4ce9e1d4135
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Target Milestone: --- → Firefox 17

Comment 15

13 days ago
i have reproduce this bug on nightly 17.0a1 windows 10 64 bit
 Mozilla/5.0 (Windows NT 6.2; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
and verified on firefox 54.0b7
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0 
[testday-20170512]
You need to log in before you can comment on or make changes to this bug.