Link error in js/: js: hidden symbol `deflateInit_' isn't defined when using system zlib

RESOLVED FIXED in mozilla17

Status

()

Core
Build Config
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mounir, Assigned: glandium)

Tracking

Trunk
mozilla17
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
With gcc-4.5.3.

Comment 1

5 years ago
Is this bug 776126?
(Reporter)

Comment 2

5 years ago
I think so.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 776126
(Reporter)

Comment 3

5 years ago
Hmm, maybe not.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 4

5 years ago
I assume you've done the whole clobber/autoreconf dance?
(Reporter)

Comment 5

5 years ago
`rm -rf objdir && make -f client.mk`
should be enough?

The difference between this bug and the other is that I'm not using the same mozconfig options: I'm not using a shared js but I'm using a system zlib.
(Reporter)

Comment 6

5 years ago
I confirm, it's because of system-zlib.

Comment 7

5 years ago
Fails for me, too.
Assignee: general → nobody
Component: JavaScript Engine → Build Config
Summary: Link error in js/: js: hidden symbol `deflateInit_' isn't defined → Link error in js/: js: hidden symbol `deflateInit_' isn't defined when using system zlib
(Assignee)

Comment 8

5 years ago
Can you attach your build log? I can't reproduce.
(Assignee)

Updated

5 years ago
Blocks: 763651

Comment 9

5 years ago
I can reproduce this bug during building Thunderbird but not reproduce during XULrunner.

Comment 10

5 years ago
Build environment:
Fedora 17 x86_64
gcc-4.7.0
zlib-1.2.5
(Assignee)

Comment 11

5 years ago
Ah, I finally reproduced.
(Assignee)

Updated

5 years ago
Assignee: nobody → mh+mozilla
(Assignee)

Comment 12

5 years ago
Created attachment 644848 [details] [diff] [review]
Fix building spidermonkey with system zlib after bug 761723
Attachment #644848 - Flags: review?(khuey)
(Assignee)

Comment 13

5 years ago
For those who would apply the patch: note ccache is not being very helpful in this case. 
Use CCACHE_RECACHE=1 make -C objdir/js/src jsutil.o
Attachment #644848 - Flags: review?(khuey) → review+

Updated

5 years ago
Duplicate of this bug: 776489
(Assignee)

Comment 15

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/eecd3aa199e6
Target Milestone: --- → mozilla17
Push backed out for Windows mochitest crashes:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=eecd3aa199e6

https://hg.mozilla.org/integration/mozilla-inbound/rev/1abfd50c8be6
(Assignee)

Comment 17

5 years ago
Relanded, as it was innocent
https://hg.mozilla.org/integration/mozilla-inbound/rev/64de88e18420
https://hg.mozilla.org/mozilla-central/rev/64de88e18420
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.