Last Comment Bug 776333 - "ASSERTION: We forgot to Morph a slim wrapper!" with Components.lookupMethod
: "ASSERTION: We forgot to Morph a slim wrapper!" with Components.lookupMethod
Status: RESOLVED FIXED
: assertion, regression, testcase
Product: Core
Classification: Components
Component: XPConnect (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- critical (vote)
: mozilla17
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 326633 774245
  Show dependency treegraph
 
Reported: 2012-07-22 00:47 PDT by Jesse Ruderman
Modified: 2014-01-10 10:40 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified


Attachments
testcase (asserts fatally when loaded) (203 bytes, text/html)
2012-07-22 00:47 PDT, Jesse Ruderman
no flags Details
stack traces (19.32 KB, text/plain)
2012-07-22 00:47 PDT, Jesse Ruderman
no flags Details
Morph slim wrappers in LookupMethod. v1 (1.96 KB, patch)
2012-07-23 06:47 PDT, Bobby Holley (:bholley) (busy with Stylo)
mrbkap: review+
Details | Diff | Splinter Review

Description Jesse Ruderman 2012-07-22 00:47:04 PDT
Created attachment 644734 [details]
testcase (asserts fatally when loaded)

###!!! ASSERTION: We forgot to Morph a slim wrapper!: 'clasp->ext.innerObject || IS_WN_WRAPPER_OBJECT(obj)', file js/xpconnect/wrappers/WrapperFactory.cpp, line 283

Assertion failure: (DebugCheckWrapperClass(obj) && !js::GetReservedSlot(obj, 0).isDouble()), at js/xpconnect/wrappers/XrayWrapper.cpp:440

Might be a regression from bug 774245.
Comment 1 Jesse Ruderman 2012-07-22 00:47:45 PDT
Created attachment 644735 [details]
stack traces
Comment 2 Bobby Holley (:bholley) (busy with Stylo) 2012-07-23 06:43:15 PDT
*** Bug 776328 has been marked as a duplicate of this bug. ***
Comment 3 Bobby Holley (:bholley) (busy with Stylo) 2012-07-23 06:47:39 PDT
Created attachment 644916 [details] [diff] [review]
Morph slim wrappers in LookupMethod. v1

We're not going through PrepareForUnwrapping, so we need to manually morph slim wrappers.
Comment 4 Bobby Holley (:bholley) (busy with Stylo) 2012-07-25 09:19:50 PDT
pushed to m-i:
http://hg.mozilla.org/integration/mozilla-inbound/rev/8eaf364324ce
Comment 5 Ed Morley [:emorley] 2012-07-26 05:12:06 PDT
https://hg.mozilla.org/mozilla-central/rev/8eaf364324ce
Comment 6 Mihaela Velimiroviciu (:mihaelav) 2012-10-19 08:37:21 PDT
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:17.0) Gecko/17.0 Firefox/17.0

Verified the fix on latest Firefox 17 beta debug build on Mac Os X 10.7.5 and doesn't assert.
Marking verified for Firefox 17.
Comment 7 Tracy Walker [:tracy] 2014-01-10 10:40:01 PST
mass remove verifyme requests greater than 4 months old

Note You need to log in before you can comment on or make changes to this bug.