crash in nsACString_internal::MutatePrep with abort message: "###!!! ABORT: OOM: file e:\builds\moz2_slave\m-cen-w32-ntly\build\xpcom\string\src\nsTSubstring.cpp, line 533"

RESOLVED WONTFIX

Status

()

defect
--
critical
RESOLVED WONTFIX
7 years ago
10 months ago

People

(Reporter: scoobidiver, Unassigned)

Tracking

({crash, regression})

16 Branch
All
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

It's similar to bug 767343.
It first appeared in 16.0a1/20120620.

Signature 	mozalloc_abort(char const* const) | NS_DebugBreak_P | nsACString_internal::MutatePrep(unsigned int, char**, unsigned int*) More Reports Search
UUID	2563075a-b445-49df-ae32-59fd72120722
Date Processed	2012-07-22 19:38:26
Uptime	373
Last Crash	7.1 minutes before submission
Install Age	2.9 hours since version was first installed.
Install Time	2012-07-22 16:40:59
Product	Firefox
Version	17.0a1
Build ID	20120722030555
Release Channel	nightly
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
Build Architecture	x86
Build Architecture Info	GenuineIntel family 6 model 15 stepping 6
Crash Reason	EXCEPTION_BREAKPOINT
Crash Address	0x72381999
App Notes 	
AdapterVendorID: 0x1002, AdapterDeviceID: 0x71c5, AdapterSubsysID: 00681854, AdapterDriverVersion: 8.561.0.0
DWrite? DWrite+ D3D10 Layers? D3D10 Layers- D3D9 Layers? D3D9 Layers- xpcom_runtime_abort(###!!! ABORT: OOM: file e:\builds\moz2_slave\m-cen-w32-ntly\build\xpcom\string\src\nsTSubstring.cpp, line 533)
EMCheckCompatibility	False
Adapter Vendor ID	0x1002
Adapter Device ID	0x71c5
Total Virtual Memory	2147352576
Available Virtual Memory	349659136
System Memory Use Percentage	87
Available Page File	2240040960
Available Physical Memory	341073920

Frame 	Module 	Signature 	Source
0 	mozalloc.dll 	mozalloc_abort 	memory/mozalloc/mozalloc_abort.cpp:23
1 	xul.dll 	NS_DebugBreak_P 	xpcom/base/nsDebugImpl.cpp:410
2 	xul.dll 	nsACString_internal::MutatePrep 	xpcom/string/src/nsTSubstring.cpp:130
3 	xul.dll 	nsScriptableInputStream::ReadBytes 	xpcom/io/nsScriptableInputStream.cpp:66
4 	xul.dll 	XPCWrappedNative::CallMethod 	js/xpconnect/src/XPCWrappedNative.cpp:2382
5 	xul.dll 	XPC_WN_CallMethod 	js/xpconnect/src/XPCWrappedNativeJSOps.cpp:1474
6 	mozjs.dll 	js::InvokeKernel 	js/src/jsinterp.cpp:345
7 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:2426
8 	mozjs.dll 	js::InvokeKernel 	js/src/jsinterp.cpp:356
9 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:388
10 	mozjs.dll 	js::CrossCompartmentWrapper::call 	js/src/jswrapper.cpp:708
11 	mozjs.dll 	proxy_Call 	js/src/jsproxy.cpp:1682
...

More reports at:
https://crash-stats.mozilla.com/report/list?signature=mozalloc_abort%28char+const*+const%29+|+NS_DebugBreak_P+|+nsACString_internal%3A%3AMutatePrep%28unsigned+int%2C+char**%2C+unsigned+int*%29
Hardware: x86 → All
it has something to do with cache.
removing files in cache directory resolved problem with similar sympthoms for me
Crash Signature: [@ mozalloc_abort(char const* const) | NS_DebugBreak_P | nsACString_internal::MutatePrep(unsigned int, char**, unsigned int*)] → [@ mozalloc_abort(char const* const) | NS_DebugBreak_P | nsACString_internal::MutatePrep(unsigned int, char**, unsigned int*)] [@ mozalloc_abort | NS_DebugBreak_P | nsACString_internal::MutatePrep]
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → WONTFIX
Closing because no crash reported since 12 weeks.
You need to log in before you can comment on or make changes to this bug.