Last Comment Bug 776480 - B2G RIL: missing handler for ipc message 'RIL:GetRadioState'
: B2G RIL: missing handler for ipc message 'RIL:GetRadioState'
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: unspecified
: ARM Gonk (Firefox OS)
: -- normal (vote)
: mozilla17
Assigned To: Yoshi Huang[:allstars.chh]
:
Mentors:
Depends on:
Blocks: b2g-ril
  Show dependency treegraph
 
Reported: 2012-07-23 04:08 PDT by Hsin-Yi Tsai [:hsinyi]
Modified: 2012-07-25 08:10 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.85 KB, patch)
2012-07-24 00:47 PDT, Yoshi Huang[:allstars.chh]
philipp: review+
Details | Diff | Splinter Review

Description Hsin-Yi Tsai [:hsinyi] 2012-07-23 04:08:31 PDT
In 'RILContentHelper.js' we send a sync message 'RIL:GetRadioState' to request radio info. However, there is no corresponding handler for this ipc message.
Comment 1 Hsin-Yi Tsai [:hsinyi] 2012-07-23 04:11:01 PDT
(In reply to Hsin-Yi Tsai [:hsinyi] from comment #0)
> In 'RILContentHelper.js' we send a sync message 'RIL:GetRadioState' to
> request radio info. However, there is no corresponding handler for this ipc
> message.

Seems this is the regression of 762760? Maybe we should replace "RIL:GetRadioState" with "RIL:GetRilContext" ?
Comment 2 Hsin-Yi Tsai [:hsinyi] 2012-07-23 04:13:35 PDT
(In reply to Hsin-Yi Tsai [:hsinyi] from comment #1)
> (In reply to Hsin-Yi Tsai [:hsinyi] from comment #0)
> > In 'RILContentHelper.js' we send a sync message 'RIL:GetRadioState' to
> > request radio info. However, there is no corresponding handler for this ipc
> > message.
> 
> Seems this is the regression of bug 762760 ? Maybe we should replace
> "RIL:GetRadioState" with "RIL:GetRilContext" ?
Comment 3 Philipp von Weitershausen [:philikon] 2012-07-23 17:55:35 PDT
Yes, good find. Can you fix? Thanks!
Comment 4 Yoshi Huang[:allstars.chh] 2012-07-23 19:34:42 PDT
I'll take it since it's my mistake.
Thanks for spotting this.
Comment 5 Yoshi Huang[:allstars.chh] 2012-07-24 00:47:46 PDT
Created attachment 645218 [details] [diff] [review]
Patch

rename IPC message "GetRadioState" to "GetRilContext" in RILContentHelper.js
Comment 6 Yoshi Huang[:allstars.chh] 2012-07-24 19:26:07 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/288c6ff3dfd8
Comment 7 Ed Morley [:emorley] 2012-07-25 08:10:11 PDT
https://hg.mozilla.org/mozilla-central/rev/288c6ff3dfd8

Note You need to log in before you can comment on or make changes to this bug.