Last Comment Bug 776537 - configure hangs in |running develop|
: configure hangs in |running develop|
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86_64 Linux
: -- blocker (vote)
: mozilla17
Assigned To: Justin Lebar (not reading bugmail)
:
Mentors:
Depends on: 788464
Blocks: 774106
  Show dependency treegraph
 
Reported: 2012-07-23 07:58 PDT by Justin Lebar (not reading bugmail)
Modified: 2012-09-05 04:40 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch, v1 (1.05 KB, patch)
2012-07-23 09:41 PDT, Justin Lebar (not reading bugmail)
mh+mozilla: review-
Details | Diff | Review
Patch, v2 (2.14 KB, patch)
2012-07-23 09:52 PDT, Justin Lebar (not reading bugmail)
mh+mozilla: review+
Details | Diff | Review

Description Justin Lebar (not reading bugmail) 2012-07-23 07:58:55 PDT
My clobber, debug Linux 64 build of the tip of m-i (4e95ccf43b6e) is currently hung at:

  Creating Python virtualenv
  New python executable in ./_virtualenv/bin/python2.7
  Also creating executable in ./_virtualenv/bin/python
  Installing setuptools............done.
  Installing pip...............done.
  Populating Python virtualenv
  running develop

We've been hung here for at least five minutes.  Top shows that python is using 100% of a CPU.
Comment 1 Justin Lebar (not reading bugmail) 2012-07-23 08:00:42 PDT
  srcdir$ find . -name '*.pyc' | xargs rm

did not fix the problem for me.
Comment 2 Mike Hommey [:glandium] 2012-07-23 08:08:41 PDT
What process(es) are sucking the cpu?
Comment 3 Justin Lebar (not reading bugmail) 2012-07-23 08:17:42 PDT
/home/jlebar/code/moz/ff-inbound/debug/_virtualenv/bin/python /home/jlebar/code/moz/ff-inbound/src/other-licenses/simplejson-2.1.1/setup.py develop
Comment 4 Justin Lebar (not reading bugmail) 2012-07-23 09:18:26 PDT
Looking at the environment we pass to setup.py, I see:

'LDFLAGS': '$(LDFLAGS)'
'CFLAGS': '$(CFLAGS) -DXP_UNIX'

That doesn't seem right...
Comment 5 Gregory Szorc [:gps] 2012-07-23 09:34:23 PDT
Did I use the wrong braces in the configure.in patch in https://hg.mozilla.org/integration/mozilla-inbound/rev/fda9279d7031?
Comment 6 Justin Lebar (not reading bugmail) 2012-07-23 09:41:03 PDT
Created attachment 644960 [details] [diff] [review]
Patch, v1

I have no idea if this is the best way to expand these variables.
Comment 7 Mike Hommey [:glandium] 2012-07-23 09:43:16 PDT
Comment on attachment 644960 [details] [diff] [review]
Patch, v1

Review of attachment 644960 [details] [diff] [review]:
-----------------------------------------------------------------

::: configure.in
@@ +8801,2 @@
>    CC="${CC}" CXX="${CXX}" \
> +  CFLAGS="$(eval echo "${HOST_CFLAGS}")" CXXFLAGS="$(eval echo "${HOST_CXXFLAGS}")" \

You should just change the initial definitions at the top of configure.in to match those used for the cross-compile case.
Comment 8 Justin Lebar (not reading bugmail) 2012-07-23 09:45:45 PDT
I didn't do that because jcranmer said it would cause problems:

  <jcranmer> glandium, jlebar: while "freezing" the HOST_* flags at compile time would be nice, I've found that a lot of builds break if you do it

Do you two want to duke it out?
Comment 9 Justin Lebar (not reading bugmail) 2012-07-23 09:52:01 PDT
Created attachment 644966 [details] [diff] [review]
Patch, v2

jcranmer tells me I misunderstood him, so here you go.  :)
Comment 10 Justin Lebar (not reading bugmail) 2012-07-23 10:09:53 PDT
This is failing on buildbots with https://tbpl.mozilla.org/php/getParsedLog.php?id=13775717&tree=Mozilla-Inbound#error0 , although I don't know what that means.
Comment 11 Justin Lebar (not reading bugmail) 2012-07-23 10:49:16 PDT
Landed: https://hg.mozilla.org/integration/mozilla-inbound/rev/603215dd3a5e
Then backed out due to the failure in comment 10: https://hg.mozilla.org/integration/mozilla-inbound/rev/28c7063c8cda
Then re-landed with Makefile.in fixes from glandium: https://hg.mozilla.org/integration/mozilla-inbound/rev/bfd0d06e1a78
Comment 12 Ed Morley [:emorley] 2012-07-24 03:02:08 PDT
https://hg.mozilla.org/mozilla-central/rev/bfd0d06e1a78

Note You need to log in before you can comment on or make changes to this bug.