Last Comment Bug 776539 - Move FormData to Paris bindings
: Move FormData to Paris bindings
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla20
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
Mentors:
Depends on:
Blocks: 819328
  Show dependency treegraph
 
Reported: 2012-07-23 08:03 PDT by :Ms2ger (⌚ UTC+1/+2)
Modified: 2012-12-12 02:10 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
WIP (7.00 KB, patch)
2012-07-23 08:03 PDT, :Ms2ger (⌚ UTC+1/+2)
no flags Details | Diff | Splinter Review
Patch v1 (23.94 KB, patch)
2012-12-07 06:14 PST, :Ms2ger (⌚ UTC+1/+2)
bzbarsky: review+
Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2012-07-23 08:03:29 PDT
Created attachment 644929 [details] [diff] [review]
WIP

This doesn't build, because of workers.
Comment 1 Boris Zbarsky [:bz] 2012-07-23 10:40:46 PDT
What's the build failure, exactly?
Comment 2 :Ms2ger (⌚ UTC+1/+2) 2012-12-07 06:14:51 PST
Created attachment 689701 [details] [diff] [review]
Patch v1
Comment 3 Boris Zbarsky [:bz] 2012-12-07 09:44:56 PST
Comment on attachment 689701 [details] [diff] [review]
Patch v1

>+  "FormData interface constructor": true

Is there a bug covering this?

>+  // void append(DOMString name, Blob value, optional DOMString filename);

You might as well uncomment that and just have the implementation ignore the last arg, which is what would happen anyway right now, just in binding code.  Would make it simpler to later update things to have it work.

r=me with that.
Comment 4 :Ms2ger (⌚ UTC+1/+2) 2012-12-07 11:17:53 PST
(In reply to Boris Zbarsky (:bz) from comment #3)
> Comment on attachment 689701 [details] [diff] [review]
> Patch v1
> 
> >+  "FormData interface constructor": true
> 
> Is there a bug covering this?

Bug 793151, which I guess I should land.
Comment 5 Boris Zbarsky [:bz] 2012-12-07 11:24:42 PST
Yes, please!
Comment 6 Boris Zbarsky [:bz] 2012-12-09 20:06:53 PST
We should land this sooner rather than later, because until we do xhr send() is kinda broken if passed in a random object...
Comment 7 :Ms2ger (⌚ UTC+1/+2) 2012-12-11 11:35:14 PST
When bz asks...

https://hg.mozilla.org/integration/mozilla-inbound/rev/2fb469965c13
Comment 8 Ed Morley [:emorley] 2012-12-12 02:10:41 PST
https://hg.mozilla.org/mozilla-central/rev/2fb469965c13

Note You need to log in before you can comment on or make changes to this bug.