Last Comment Bug 776773 - tab bar loses active tab when window is maximized
: tab bar loses active tab when window is maximized
Status: RESOLVED FIXED
: regression
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: Trunk
: All Windows 7
: -- normal (vote)
: Firefox 17
Assigned To: Dão Gottwald [:dao]
:
:
Mentors:
Depends on:
Blocks: 624157
  Show dependency treegraph
 
Reported: 2012-07-23 17:24 PDT by eyal gruss (eyaler)
Modified: 2012-07-26 14:08 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
small window (167.63 KB, image/png)
2012-07-23 17:24 PDT, eyal gruss (eyaler)
no flags Details
maximized window (211.86 KB, image/png)
2012-07-23 17:25 PDT, eyal gruss (eyaler)
no flags Details
put tabs in the title bar before updating the tab strip (2.44 KB, patch)
2012-07-26 05:45 PDT, Dão Gottwald [:dao]
ttaubert: review+
Details | Diff | Splinter Review

Description eyal gruss (eyaler) 2012-07-23 17:24:26 PDT
Created attachment 645138 [details]
small window

1. open 20 tabs
2. make the firefox window small
3. choose the last tab
4. maximize the window using the maximize button

actual: selected tab is out of tab bar scope

expected: selected tab remains in tab bar scope
Comment 1 eyal gruss (eyaler) 2012-07-23 17:25:00 PDT
Created attachment 645139 [details]
maximized window
Comment 2 Alice0775 White 2012-07-25 10:41:12 PDT
Regression window
Good:
http://hg.mozilla.org/mozilla-central/rev/814b67490af5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110119 Firefox/4.0b10pre ID:20110120063351
Bad:
http://hg.mozilla.org/mozilla-central/rev/14fd87c263b6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110120 Firefox/4.0b10pre ID:20110120074206
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=814b67490af5&tochange=14fd87c263b6

Regressed by: Bug 624157
Comment 3 Dão Gottwald [:dao] 2012-07-26 05:45:54 PDT
Created attachment 646107 [details] [diff] [review]
put tabs in the title bar before updating the tab strip

This bug is caused by TabsInTitlebar's resize handler running after the tabbrowser-tabs binding's resize handler.
Comment 5 Matt Brubeck (:mbrubeck) 2012-07-26 14:08:15 PDT
https://hg.mozilla.org/mozilla-central/rev/b571e6fddb8f

Note You need to log in before you can comment on or make changes to this bug.