Last Comment Bug 776822 - Many Makefile's from dom/ missing from toolkit-makefiles.sh
: Many Makefile's from dom/ missing from toolkit-makefiles.sh
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla17
Assigned To: Gregory Szorc [:gps]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-23 22:42 PDT by Gregory Szorc [:gps]
Modified: 2012-07-31 06:11 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add missing Makefile's in dom/, v1 (5.86 KB, patch)
2012-07-26 22:56 PDT, Gregory Szorc [:gps]
khuey: review+
Details | Diff | Review

Description Gregory Szorc [:gps] 2012-07-23 22:42:27 PDT
There are a number of Makefile's in dom/ missing from allmakefiles.sh.

Non-comprehensive list:

dom/interfaces/settings/Makefile
dom/apps/Makefile
dom/bindings/Makefile
dom/browser-element/Makefile
dom/devicestorage/Makefile
dom/contacts/Makefile
dom/media/Makefile
dom/settings/Makefile
dom/mms/Makefile
dom/identity/Makefile
dom/imptests/Makefile
dom/bindings/test/Makefile
Comment 1 Gregory Szorc [:gps] 2012-07-23 22:48:38 PDT
Errr - I guess there is some magic going on inside dom/. Possibly inherited from dom-config.mk? I have a feeling I shouldn't go down this rabbit hole...
Comment 2 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-07-24 05:14:52 PDT
allmakefiles.sh is a performance optimization.  Not being listed doesn't break anything, *unless* the directory omitted is a top-level directory (it's built from tier_*_dirs and not from DIRS or PARALLEL_DIRS).
Comment 3 Gregory Szorc [:gps] 2012-07-26 22:56:32 PDT
Created attachment 646474 [details] [diff] [review]
Add missing Makefile's in dom/, v1

This avoid make-makefile in dom/ in my local build.

Try at http://tbpl.mozilla.org/?tree=Try&rev=5a42ea6ea663. Maybe. Try seems to be having issues.
Comment 4 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-07-30 16:02:05 PDT
Comment on attachment 646474 [details] [diff] [review]
Add missing Makefile's in dom/, v1

Review of attachment 646474 [details] [diff] [review]:
-----------------------------------------------------------------

I didn't actually look at this.  I assume you know what you're doing.
Comment 6 Ed Morley [:emorley] 2012-07-31 06:11:41 PDT
https://hg.mozilla.org/mozilla-central/rev/375d278adbd1

Note You need to log in before you can comment on or make changes to this bug.