Last Comment Bug 776918 - The rest of the nullptr related build errors with vc11
: The rest of the nullptr related build errors with vc11
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal (vote)
: mozilla17
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks: 626472 VC11
  Show dependency treegraph
 
Reported: 2012-07-24 07:41 PDT by Jim Mathies [:jimm]
Modified: 2012-07-26 05:13 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.60 KB, patch)
2012-07-24 08:09 PDT, Jim Mathies [:jimm]
netzen: review+
Details | Diff | Splinter Review

Description Jim Mathies [:jimm] 2012-07-24 07:41:29 PDT
no need to keep filing new bugs, these are all smallish changes.
Comment 1 Jim Mathies [:jimm] 2012-07-24 07:41:55 PDT
nsParentalControlsServiceWin.cpp
f:/Mozilla/firefox/mc/toolkit/components/parentalcontrols/nsParentalControlsServiceWin.cpp(47) : error C2440: 'initializing' : cannot convert from 'nullptr' to 'REGHANDLE'
        A native nullptr can only be converted to bool or, using reinterpret_cast, to an integral type
f:/Mozilla/firefox/mc/toolkit/components/parentalcontrols/nsParentalControlsServiceWin.cpp(47) : error C2439: 'nsParentalControlsServiceWin::mProvider' : member could not be initialized
        f:\mozilla\firefox\mc\toolkit\components\parentalcontrols\nsParentalControlsServiceWin.h(34) : see declaration of 'nsParentalControlsServiceWin::mProvider'
make[5]: *** [nsParentalControlsServiceWin.obj] Error 2
Comment 2 Jim Mathies [:jimm] 2012-07-24 07:48:21 PDT
dlldeps-xul.cpp
f:/Mozilla/firefox/mc/toolkit/library/dlldeps-xul.cpp(9) : error C2664: 'XRE_main' : cannot convert parameter 4 from 'nullptr' to 'PRUint32'
        A native nullptr can only be converted to bool or, using reinterpret_cast, to an integral type
make[1]: *** [dlldeps-xul.obj] Error 2
Comment 3 Jim Mathies [:jimm] 2012-07-24 08:09:14 PDT
Created attachment 645306 [details] [diff] [review]
patch

The parental controls one is obvious. The XRE-main one is actually a bug from the metro work, that should have been zero since it's a flag, not a ptr.
Comment 4 Ed Morley [:emorley] 2012-07-26 05:13:23 PDT
https://hg.mozilla.org/mozilla-central/rev/fe77957061ea

Note You need to log in before you can comment on or make changes to this bug.