Update in-tree copies of mozmill to pick up bug 558220's httpd.js fix

RESOLVED DUPLICATE of bug 1068011

Status

Testing
httpd.js
RESOLVED DUPLICATE of bug 1068011
6 years ago
3 years ago

People

(Reporter: emorley, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Bug fixed a bug in httpd.js, to quote bz:

"Fixed a bug in the test HTTP header that caused it to misread headers when a packet boundary fell between the CR and LF at the end of a header value"

The change was applied to:
/netwerk/test/httpserver/httpd.js

However in-tree, we also have:
/services/sync/tps/extensions/mozmill/resource/stdlib/httpd.js
/testing/peptest/peptest/extension/resource/mozmill/stdlib/httpd.js
(In reply to Ed Morley [:edmorley] from comment #0)
> Bug fixed a bug in httpd.js

Bah, bug 558220
Depends on: 558220
CC'ing the people that imported mozmill into various parts of the tree.

The following mozmill commit picked up the changes from bug 558220:
https://github.com/mozilla/mozmill/commit/4aabbe9c1642336c84e7aee3f12c11fb4c38827e

...so all we need is an update of the mozmill import for both services/sync/tps/extensions/mozmill/ and testing/peptest/peptest/extension/resource/mozmill/
Summary: Update all in-tree copies of httpd.js with the fix from bug 558220 → Update in-tree copies of mozmill to pick up bug 558220's httpd.js fix
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1068011
You need to log in before you can comment on or make changes to this bug.