Closed Bug 777008 Opened 8 years ago Closed 8 years ago

[adbe 3308053] startup crash in F_1330260112

Categories

(Core :: Plug-ins, defect)

15 Branch
x86
Windows 7
defect
Not set
critical

Tracking

()

VERIFIED FIXED

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash, topcrash, Whiteboard: [startupcrash][Flash-11.3][Flash-11.4][Fixed in Flash 11.5])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-c5c29ba4-a7a0-45ef-94b4-32b782120724 .
============================================================= 

Windows 7 	87.158 %	319
Windows Vista 	10.929 %	 40
Windows 8 	1.913 %	          7 

11.3.300.265 	64.481 % 	236
11.3.300.257 	33.333 % 	122
11.3.300.231 	2.186 % 	8 

Seen while looking at Firefox beta crashes. https://crash-stats.mozilla.com/report/list?signature=F_1330260112_______________________________. Highest concentration of crashes on Beta so far.

Frame 	Module 	Signature 	Source
0 	NPSWF32_11_3_300_265.dll 	F_1330260112_______________________________ 	F_2053675896____________________________________________:4629
1 	NPSWF32_11_3_300_265.dll 	F1812794833_________________________ 	F1556456750_______________________________________:3230
2 	NPSWF32_11_3_300_265.dll 	F1980088851__________________________ 	F1556456750_______________________________________:3267
3 	NPSWF32_11_3_300_265.dll 	F1270095782_________________________ 	F_1900438979_________________________________________:31594
4 	NPSWF32_11_3_300_265.dll 	F1592879982____________________________ 	F_1900438979_________________________________________:13102
5 	NPSWF32_11_3_300_265.dll 	F_1995396427_________________ 	F_1900438979_________________________________________:13356
6 	NPSWF32_11_3_300_265.dll 	F1546913566_____________________________________ 	F1157779535_________________________________________________________________________:4085
7 	NPSWF32_11_3_300_265.dll 	F957328252________________________ 	F1157779535_________________________________________________________________________:639
8 	user32.dll 	InternalCallWinProc 	
9 	user32.dll 	UserCallWinProcCheckWow 	
10 	user32.dll 	DispatchMessageWorker 	
11 	user32.dll 	DispatchMessageW 	
12 	FlashPlayerPlugin_11_3_300_265.exe 	F425467176_____________________________________________________ 	F_540393159_____________________________________________________________________:358
13 	FlashPlayerPlugin_11_3_300_265.exe 	F849276792______________________________ 	F_540393159_____________________________________________________________________:199
14 	FlashPlayerPlugin_11_3_300_265.exe 	F_1338064323______________________________________________ 	F1922230711____________________________________________________________________:80
15 	FlashPlayerPlugin_11_3_300_265.exe 	F802476640______________________ 	F674807226__________________________________________________________________:453
16 	FlashPlayerPlugin_11_3_300_265.exe 	F_138606341_____________ 	F674807226__________________________________________________________________:350
17 	FlashPlayerPlugin_11_3_300_265.exe 	F1419126855_______________________________________________________________ 	F_1358850170___________________________________________________________________:399
18 	FlashPlayerPlugin_11_3_300_265.exe 	WinMain 	F_1358850170___________________________________________________________________:552
19 	FlashPlayerPlugin_11_3_300_265.exe 	__tmainCRTStartup 	f:\dd\vctools\crt_bld\self_x86\crt\src\crt0.c:263
20 	kernel32.dll 	BaseThreadInitThunk 	
21 	ntdll.dll 	__RtlUserThreadStart 	
22 	ntdll.dll 	_RtlUserThreadStart
OS: Windows NT → Windows 7
Whiteboard: [startupcrash] → [startupcrash][Flash-11.3]
This is #2 in the 11.4.400.252 topcrashes: https://crash-analysis.mozilla.com/rkaiser/2012-08-08/2012-08-08.firefox.flash.11-4-400-252.html

That seems to indicate this happens more frequently with 11.4 than it did with 11.3, where it was first introduced.
Whiteboard: [startupcrash][Flash-11.3] → [startupcrash][Flash-11.3][Flash-11.4]
Is this a dupe of 777433?
(In reply to Jeromie Clark from comment #2)
> Is this a dupe of 777433?

Nevermind, had my windows confused.  This is Adobe Internal 3308053
Summary: startup crash in F_1330260112 → [adbe 3308053] startup crash in F_1330260112
According to the Signature Summary, this is still occurring with Version 11.4.402.265.
We're aware of the issue, but don't have enough information to make it actionable.  We've done an extensive analysis and attempted to implement a blind fix, but the data coming in from the field indicates that it's not effective.
It's #17 top crasher in 15.0.1.
Keywords: topcrash
#18 in Firefox beta as well.
Here is a snapshot of crashes in the last week across all Firefox versions:

Operating System 	Percentage 	Number Of Crashes
Windows 7 	        82.565 %	11517
Windows Vista 	        17.091 %	2384
Windows 8 	         0.337 %	47
Windows XP 	         0.007 %	1
We implemented a revised blind fix for this issue in Flash Player 11.5.500.90 that appears to have fixed this issue.  

We're no longer seeing the crash report in the stats for the current build, but are still picking up a significant number of pings in older beta versions. 

If you've been running into this crash, please download the latest Flash Player beta at http://www.adobe.com/go/flashplayerbeta.
Let's call this FIXED and reopen if data shows otherwise.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [startupcrash][Flash-11.3][Flash-11.4] → [startupcrash][Flash-11.3][Flash-11.4][Fixed in Flash 11.5]
There are 5 crashes in 11.5.500.80 and no crashes in higher versions.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.