Allow editing of page source in developer tools

RESOLVED DUPLICATE of bug 895561

Status

--
enhancement
RESOLVED DUPLICATE of bug 895561
6 years ago
2 months ago

People

(Reporter: kevinjduke, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:16.0) Gecko/16.0 Firefox/16.0
Build ID: 20120724042008




Expected results:

Developer tools should allow editing of page source like Firebug can. Currently, editing is limited to double clicking on some attributes, but we cannot add attributes or change them entirely. This is the only thing keeping my firebug addon. Possible to add a right-click entry for "edit" which would allow editing of that line?
(Reporter)

Updated

6 years ago
Severity: normal → enhancement
Component: Untriaged → Developer Tools: Source Editor
OS: Windows 7 → All
Hardware: x86 → All

Updated

6 years ago
Component: Developer Tools: Source Editor → Developer Tools
(Reporter)

Updated

6 years ago
Version: 16 Branch → unspecified
(Reporter)

Comment 1

6 years ago
Also, not all values are able to be changed currently, like text and others. It should allow anything to be edited.
(Reporter)

Comment 2

5 years ago
CSS can now be edited freely, now all we need is HTML editing!
All values, including text, can be edited now. However, you can not add arbitrary additional HTML or edit more than one element at a time. This is possible in Firebug by selecting a parent element to edit (you can edit all HTML contained in that element). Yes, please.
(Reporter)

Comment 4

5 years ago
Yes HTML can be edited but it is very tedious to do so currently. Free-style html editing like in Firebug is needed, at least as an option.
Free style HTML editing will be handled in Bug 895561.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 895561

Updated

2 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.