Race condition in showing doorhanger

RESOLVED DUPLICATE of bug 732336

Status

()

RESOLVED DUPLICATE of bug 732336
6 years ago
6 years ago

People

(Reporter: kats, Assigned: Margaret)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Spun out from https://bugzilla.mozilla.org/show_bug.cgi?id=775614#c7:

What is happening on startup is:

1) telemetry code gets initialized and sends the telemetry "show doorhanger" message to java
2) java processes that message and enters GeckoApp.handleDoorHanger, which defers the actual creation of the doorhanger to a runnable on the UI thread
3) the about:home page gets loaded and sends a location change event to java. the doorhanger is not yet created and so this location change doesn't decrement the doorhanger's persistence counter as expected
4) the doorhanger is created with mPersistence=1, and so lasts until after another page has loaded.

This could occur during normal browsing as well, if a new page is navigated to in between steps 2 and 4, and could result in a doorhanger from the previous page showing up on the current page.
(Assignee)

Updated

6 years ago
Assignee: nobody → margaret.leibovic
(Assignee)

Updated

6 years ago
Depends on: 732336
(Assignee)

Comment 1

6 years ago
Bug 732336 addressed this race condition. Now the new DoorHanger is immediately created and added to a set of notifications when we get the "Doorhanger:Add" message in Java.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 732336
You need to log in before you can comment on or make changes to this bug.