Outline CSS property does not work in XUL.

VERIFIED DUPLICATE of bug 22892

Status

()

VERIFIED DUPLICATE of bug 22892
18 years ago
10 years ago

People

(Reporter: pwilson, Assigned: trudelle)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I know this is a duplicate of #22892, but a comment I added to that one remains 
unanswered. I am re-adding this in the hope of re-starting work on this problem.

I now well advanced in developing an IDE for XUL applications. The lack of an 
effective way to indicate the selection of widgets is severely hampering this 
effort. The original bug suggested that this feature was of marginal interest 
for XUL - NOT TRUE.

Alternatives to indicate:

1. Use addition/removal of border around selected elements.
 Does not work, several widgets already use the border area for their UI - eg 
button. Inserting a new box parent would solve this but would still cause the 
form to be re-flowed.

2. Overlay Form display area with a stack containing a bulletin board. 
Move/resize a box arround the bulletin board to indicate the selection.
Works only partially - screen resize moves widgets but not selection (which is 
fixed). Also D&D may not be possible on the widgets as they do not receive mouse 
events - these go to the bulletin board. It may be possible to work around this 
- but at a great increase in complexity.

Please reconsider.
(Reporter)

Updated

18 years ago
Severity: normal → blocker

Comment 1

18 years ago
not a blocker by a long shot, -> xpt: xul
Assignee: asa → trudelle
Severity: blocker → normal
Component: Browser-General → XP Toolkit/Widgets: XUL
QA Contact: doronr → jrgm
as you say, this is a duplicate.  Marking so and moving comments to original bug.

Have you tried using "-moz-outline" instead (per bug 9816)?


*** This bug has been marked as a duplicate of 22892 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

18 years ago
The -moz-outline wotks nicely.

Many, many thanks.

Comment 4

18 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

18 years ago
I spoke too soon. -moz-outline does not work for buttons using the Modern skin. 
Only a single pixel of the border appears at each corner of the button. 
The outline appears fine for the Clasic skin.

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.