Make sure child actors can't force parent to crash with Out-of-Memory (OOM) errors

RESOLVED DUPLICATE of bug 777067

Status

()

RESOLVED DUPLICATE of bug 777067
6 years ago
6 months ago

People

(Reporter: sicking, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(blocking-basecamp:-)

Details

For example by sending an array with 2^31 elements.
Summary: Make sure child actors can't crash parent process through OOP → Make sure child actors can't force parent to crash with Out-of-Memory (OOM) errors
We should specifically focus this on maliciously-crafted IPC messages triggering OOM only in the parent.  On b2g, after bug 768832 it will be impossible for content process allocations to cause the parent to be OOM-killed.
blocking-basecamp: --- → -

Comment 2

6 months ago
Christoph, would you consider this a dupe of work you are doing and closable?
Flags: needinfo?(cdiehl)
Basically, yes. There will be component specific follow up bugs where such conditions failed.
Flags: needinfo?(cdiehl)

Updated

6 months ago
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 777067
You need to log in before you can comment on or make changes to this bug.