Last Comment Bug 777220 - Temporarily disable slow SQL reporting
: Temporarily disable slow SQL reporting
Status: RESOLVED FIXED
[qa-]
:
Product: Toolkit
Classification: Components
Component: Telemetry (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla17
Assigned To: Vladan Djeric (:vladan)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-24 19:58 PDT by Vladan Djeric (:vladan)
Modified: 2012-10-18 11:22 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
wontfix
+
fixed
+
fixed
fixed


Attachments
Don't fetch slow sql in TelemetryPing.js (1.52 KB, patch)
2012-07-24 20:24 PDT, Vladan Djeric (:vladan)
nfroyd: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
akeybl: approval‑mozilla‑release-
vladan.bugzilla: checkin+
Details | Diff | Splinter Review

Description Vladan Djeric (:vladan) 2012-07-24 19:58:52 PDT
In bug 776469, we found out that prepared SQL strings reported by Telemetry sometimes contain URLs. We want to temporarily suspend slow SQL reporting until a patch that sanitizes SQL strings is ready.
Comment 1 Vladan Djeric (:vladan) 2012-07-24 20:24:44 PDT
Created attachment 645634 [details] [diff] [review]
Don't fetch slow sql in TelemetryPing.js
Comment 2 Vladan Djeric (:vladan) 2012-07-24 21:25:46 PDT
Comment on attachment 645634 [details] [diff] [review]
Don't fetch slow sql in TelemetryPing.js

[Approval Request Comment]
Regression caused by (bug #): 699051
User impact if declined: Users using certain addons may end up submitting private data to Telemetry
Testing completed (on m-c, etc.): Trivial petch, tested on mozilla-inbound
Risk to taking this patch (and alternatives if risky): No risk foreseen. Hypothetically speaking, perhaps it might interfere with Telemetry reporting if merged incorrectly
String or UUID changes made by this patch: None
Comment 3 Vladan Djeric (:vladan) 2012-07-25 09:27:00 PDT
Comment on attachment 645634 [details] [diff] [review]
Don't fetch slow sql in TelemetryPing.js

https://hg.mozilla.org/integration/mozilla-inbound/rev/ae6b9545a0f4
Comment 4 Ed Morley [:emorley] 2012-07-26 05:19:56 PDT
https://hg.mozilla.org/mozilla-central/rev/ae6b9545a0f4
Comment 5 Ed Morley [:emorley] 2012-07-26 05:22:13 PDT
Setting tracking flags based on branches requested in comment 2.

I don't normally set these when merging (other than marking the m-c branch as fixed), so please make sure to do this another time so things don't accidentally get overlooked once the bug is resolved fixed post merge :-)
Comment 6 Alex Keybl [:akeybl] 2012-07-26 14:22:41 PDT
Comment on attachment 645634 [details] [diff] [review]
Don't fetch slow sql in TelemetryPing.js

[Triage Comment]
Approved for Aurora/Beta.
Comment 7 Lawrence Mandel [:lmandel] (use needinfo) 2012-07-26 14:30:17 PDT
To follow-up on the release-, given that we're implementing a server side solution to filter this data, I think we can rely on that instead of pushing for a ride along in any potential chemspill - and, afaik, there is nothing that currently warrants a chemspill with which to ride along.
Comment 9 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-10-17 16:02:29 PDT
Is there something QA can do to verify this fix?
Comment 10 Vladan Djeric (:vladan) 2012-10-18 10:16:42 PDT
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #9)
> Is there something QA can do to verify this fix?

No, in fact, bug 779310 undid this change. I think only the release channel still has slowSQL turned off
Comment 11 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-10-18 11:22:57 PDT
Okay, thanks Vladan.

Note You need to log in before you can comment on or make changes to this bug.