Nested DL elements not always indenting

VERIFIED DUPLICATE of bug 8749

Status

()

Core
HTML: Parser
P5
enhancement
VERIFIED DUPLICATE of bug 8749
17 years ago
17 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: Marc Attinasi)

Tracking

({compat})

Trunk
Future
x86
Windows 95
compat
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: quirks mode)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
In build 2001031008 the page given loads correctly. However in build 2001042404
none of the nested lists are indented.
Not a DOM problem, over to parser for futher investigation.
Assignee: jst → harishd
Component: DOM Level 0 → Parser
Keywords: mozilla0.9.1, nsbeta1, regression
QA Contact: desale → bsharma

Comment 2

17 years ago
I can confirm this on win2k build 2001042504... the easiest way to reproduce is
to load the bookmarks.html file in the browser.
Updating severity to major because... well it's a tag that doesn't work ;)
Severity: normal → major

Comment 3

17 years ago
Looks bad. Setting to m0.9.1.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.1

Comment 4

17 years ago
Created attachment 32767 [details]
Test case

Comment 5

17 years ago
Content Model:

docshell=00FEF060
html@01009860 refcount=7<
  head@01009770 refcount=2<
  >
  Text@03175200 refcount=3<\n>
  body@0317EDE0 refcount=3<
    Text@037842C0 refcount=3<\n>
    dl@03784210 style=border-top-width: medium; border-top-style: ridge; border-
top-color: red; border-right-width: medium; border-right-style: ridge; border-ri
ght-color: red; border-bottom-width: medium; border-bottom-style: ridge; border-
bottom-color: red; border-left-width: medium; border-left-style: ridge; border-l
eft-color: red;  refcount=3<
      dt@03780EC0 refcount=3<
        Text@03780E50 refcount=3<\n  >
        dl@03780DF0 refcount=3<
          dt@03780D90 refcount=3<
            Text@03780D20 refcount=3<\n     indent\n>
          >
        >
      >
    >
  >
>

Comment 6

17 years ago
It looks like the parser is doing the correct thing. Over to layout for analysis.

-->attinasi.
Assignee: harishd → attinasi
Status: ASSIGNED → NEW
(Assignee)

Comment 7

17 years ago
Interesting: I created a slightly different testcase that shows that the
indentation of nested DL's works if there is a DD in there, even if empty. I'll
attach it for those who are interested. CC'd rick as we discussed this briefly.
Status: NEW → ASSIGNED
(Assignee)

Comment 8

17 years ago
Created attachment 32932 [details]
Testcase: has nested DL with no DD and netsted DL with empty DD
(Assignee)

Comment 9

17 years ago
I think the problem is this rule that was removed from html.css by Ian back in
Sept of 2000 as part of a restructiring:

dl dl {                                                                         
 margin: 0 0 0 40px;                                                           
} 

Putting this into the testcase make the nested <DT> with not <DD> indent as I
believe the reporter expects.

CC'ing Ian to see if he remembers why that was removed...
(Assignee)

Comment 10

17 years ago
I'm changint the summary and downgrading this slightly because I do not think
that Definition Lists have really stopped working. Using DL /DT to get indenting
may have regressed, but the 'normal' use of DL / DT / DD to create definition
lists has not broken. It is still a bug, but not as critical as originally
reported. That said, it looks like an easy fix too.
Severity: major → normal
Priority: -- → P3
Summary: Definition lists have stopped working → Nested DL elements not always indenting
Target Milestone: mozilla0.9.1 → mozilla0.9.2
If we put it back it should go in quirks.css.
Severity: normal → minor
Keywords: compat
Whiteboard: WONTFIX ? -- quirks mode too quirky?
(Assignee)

Comment 12

17 years ago
OK, so, is it even a bug? Nav 4.7 does not indent the testcase the way the
author expects, but IE does, so by my seat-of-the-pants analysis I'd say this is
not even a qurik worth handling. I cannot tell, but since the rule used to be
there, and was eliminated when the agent css files were celaned up, I thought it
was worth considering.
The spec leaves it undefined. I can't really comment on whether we want to
follow Win IE or Nav 4 or Opera or Mac IE or Lynx or Konqueror as far as our
response to invalid markup goes; I have no opinion and at this point I think
we have bigger fish to fry... :-)
(Reporter)

Comment 14

17 years ago
OK I've fixed the page to validate to HTML 4.01 Transitional so you can resolve
this as invalid or wontfix or whatever.
(Assignee)

Comment 15

17 years ago
Thanks Neil, I'll mark it WONTFIX because it is a bug, just not one we want to
deal with at this time (emulating Quirks is tough business).
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Comment 16

17 years ago
Marking verified as per above developer comments.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 17

17 years ago
I've found out where I originally saw that indentation style.

It was a product called Netscape Composer 4.x

If you use it to indent a dd or a dt it just wraps an extra dl around it.

So I've reopened it but as a future enhancement to quirks.css
Severity: minor → enhancement
Status: VERIFIED → REOPENED
Keywords: mozilla0.9.1, nsbeta1, regression
Priority: P3 → P5
Resolution: WONTFIX → ---
Whiteboard: WONTFIX ? -- quirks mode too quirky? → quirks mode
Target Milestone: mozilla0.9.2 → Future
(Assignee)

Comment 18

17 years ago
Part of this was fixed with the patch for bug 8749 - closing as a dup.

*** This bug has been marked as a duplicate of 8749 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 19

17 years ago
vrfy dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.