min-height & box-sizing:border-box not working

RESOLVED DUPLICATE of bug 308801

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 308801
6 years ago
6 years ago

People

(Reporter: Jonas Jasas, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/536.11 (KHTML, like Gecko) Chrome/20.0.1132.57 Safari/536.11

Steps to reproduce:

http://jsfiddle.net/Cj8vZ/38/


Actual results:

<div class='content'> does not fit in to body,
Padding is not added to div's height.


Expected results:

<div class='content'> should fit in to body as in all other browsers.
(Reporter)

Updated

6 years ago
Severity: normal → major
Priority: -- → P4

Comment 1

6 years ago
Created attachment 645696 [details]
html

Updated

6 years ago
Component: Untriaged → Layout
Product: Firefox → Core
Summary: box-sizing:border-box not working → min-height & box-sizing:border-box not working
Version: 17 Branch → Trunk
Bug 776265?

Comment 3

6 years ago
(In reply to :Ms2ger from comment #2)
> Bug 776265?

I would say it's a dupe of bug 308801.
(Reporter)

Comment 4

6 years ago
(In reply to Loic from comment #3)
> (In reply to :Ms2ger from comment #2)
> > Bug 776265?
> 
> I would say it's a dupe of bug 308801.

7 years for this bug, looks like unfixable. Sad to see my site almost unusable with FF :(
(Reporter)

Updated

6 years ago
See Also: → bug 308801
This does indeed look like a duplicate of bug 308801.  But the patches for bug 776265 should actually fix this, I believe.

Jonas, you can get the same effect without using box-sizing by using calc() instead if you just want something that works cross-browser and doesn't depend on underspecified experimental properties...
Severity: major → normal
Depends on: 308801
Priority: P4 → --
(Reporter)

Comment 6

6 years ago
(In reply to Boris Zbarsky (:bz) from comment #5)
> This does indeed look like a duplicate of bug 308801.  But the patches for
> bug 776265 should actually fix this, I believe.
> 
> Jonas, you can get the same effect without using box-sizing by using calc()
> instead if you just want something that works cross-browser and doesn't
> depend on underspecified experimental properties...

http://caniuse.com/calc
http://caniuse.com/css3-boxsizing
Not sure which is experimental :) But anyway thank's for a good hint! Hope to work around this FF bug with calc.
The key part was "underspecified".  ;)

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
No longer depends on: 308801
Resolution: --- → DUPLICATE
Duplicate of bug: 308801
You need to log in before you can comment on or make changes to this bug.