Misplaced autocompletion dropdown with CSS transform

RESOLVED DUPLICATE of bug 467442

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 467442
6 years ago
6 years ago

People

(Reporter: ttaubert, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 645678 [details]
screencast showing the misplaced autocompletion dropdown

This is definitely not a (recent) regression. I could reproduce this with the Nightly from 2011-01-01 so I think it doesn't make any sense to further search for a regression range.

STR:

1) Open http://www.graememcc.co.uk/m-cmerge/?cset=ef20925bc2a5
2) Click the "Next" button in the upper right
3) Scroll to the bottom and click "Submit the changes above"
4) Press a key to enter a value into the "Username" field.

In case you've entered some credentials into this form before, an autocompletion dropdown will show but is positioned way too far in the lower right.

I attached a screencast that shows the described issue. (Please ignore the text not being rendered - that's bug 539356.)
(Reporter)

Comment 1

6 years ago
This is caused by the following CSS rules:

> .modal {
>   position: fixed;
>   top: 50%;
>   left: 50%;
>
>   -moz-transform: translate(-50%, -50%);
>   transform: translate(-50%, -50%);
> }
Summary: Misplaced autocompletion dropdown → Misplaced autocompletion dropdown with CSS transform
I think this is very similar to bug 664707.
OS: Linux → All
Hardware: x86_64 → All
Dupe of bug 467442?
(Reporter)

Comment 4

6 years ago
(In reply to Graeme McCutcheon [:graememcc] from comment #3)
> Dupe of bug 467442?

Yes, thanks!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 467442
You need to log in before you can comment on or make changes to this bug.