Last Comment Bug 777358 - Tab curve is low resolution on ~170DPI
: Tab curve is low resolution on ~170DPI
Status: VERIFIED FIXED
: polish, uiwanted
Product: Firefox for Android
Classification: Client Software
Component: Theme and Visual Design (show other bugs)
: 15 Branch
: ARM Android
: -- normal (vote)
: Firefox 17
Assigned To: Sriram Ramasubramanian [:sriram]
:
: Anthony Lam (:antlam)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 08:13 PDT by Aaron Train [:aaronmt]
Modified: 2012-09-27 06:33 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
verified
verified


Attachments
Firefox Beta 15.0 (Beta 2) (Screenshot) (188.92 KB, image/png)
2012-07-25 08:14 PDT, Aaron Train [:aaronmt]
no flags Details
Patch (58.79 KB, patch)
2012-07-31 11:42 PDT, Sriram Ramasubramanian [:sriram]
mark.finkle: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Aaron Train [:aaronmt] 2012-07-25 08:13:40 PDT
Galaxy Tab 2 7", 1024x600 ~170DPI look at the screenshot.

--
Tested via, Firefox Beta 15.0 (Beta 2, build #1)
Galaxy Tab 2 7" (Android 4.0.4)
Comment 1 Aaron Train [:aaronmt] 2012-07-25 08:14:14 PDT
Created attachment 645767 [details]
Firefox Beta 15.0 (Beta 2) (Screenshot)
Comment 2 Sriram Ramasubramanian [:sriram] 2012-07-27 01:05:35 PDT
I am suspecting that Android takes the drawable from a different folder (though our folders are right.. android does it at times. This was the reason for calling resources as address_bar_bg_tablet.png and so on).
I'll try renaming and see if we get any difference.
Comment 3 Sriram Ramasubramanian [:sriram] 2012-07-31 11:42:50 PDT
Created attachment 647620 [details] [diff] [review]
Patch

My initial patch has missed adding the files to Makefile.in. They have been added now.
The images weren't perfect (that were about to be added in Makefile.in). They have been replaced.
The layout had to be changed back then, as I felt something is wrong with images (without knowing I didnt add them), and I have reverted the layout changes to be in proportion with phones.
Comment 4 Sriram Ramasubramanian [:sriram] 2012-08-03 12:13:55 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/08dbf37ae570
Comment 5 Sriram Ramasubramanian [:sriram] 2012-08-03 12:15:52 PDT
Comment on attachment 647620 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): -
User impact if declined: The tab curve will be pixellated in Nexus 7.
Testing completed (on m-c, etc.): Landed in m-i on 08/03
Risk to taking this patch (and alternatives if risky): None. The images are already there. They are just added to Makefile.in (and few images were wrong -- just replaced).
String or UUID changes made by this patch: None.
Comment 6 Ed Morley [:emorley] 2012-08-04 11:19:00 PDT
https://hg.mozilla.org/mozilla-central/rev/08dbf37ae570
Comment 7 Lukas Blakk [:lsblakk] use ?needinfo 2012-08-06 12:09:07 PDT
Comment on attachment 647620 [details] [diff] [review]
Patch

low risk, mobile only, approving for branches.
Comment 8 Sriram Ramasubramanian [:sriram] 2012-08-07 11:34:52 PDT
Pushed to aurora:
https://hg.mozilla.org/releases/mozilla-aurora/rev/5c93b603dc71
Comment 9 Sriram Ramasubramanian [:sriram] 2012-08-07 11:50:57 PDT
Pushed to beta:
https://hg.mozilla.org/releases/mozilla-beta/rev/6109be88ac12
Comment 10 Cristian Nicolae (:xti) 2012-09-27 06:25:29 PDT
There is a high resolution quality for the tab curve on Galaxy Tab 2 7" on Firefox 16 beta 5.

Note You need to log in before you can comment on or make changes to this bug.