Last Comment Bug 777463 - Options missing from Firefox Button Menu
: Options missing from Firefox Button Menu
Status: VERIFIED FIXED
: regression
Product: Firefox
Classification: Client Software
Component: Menus (show other bugs)
: Trunk
: All Windows 7
: -- critical (vote)
: Firefox 17
Assigned To: Jared Wein [:jaws] (please needinfo? me)
:
:
Mentors:
Depends on:
Blocks: 764872
  Show dependency treegraph
 
Reported: 2012-07-25 12:23 PDT by Jim Jeffery not reading bug-mail 1/2/11
Modified: 2012-08-08 10:20 PDT (History)
4 users (show)
jaws: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.79 KB, patch)
2012-07-25 14:09 PDT, Jared Wein [:jaws] (please needinfo? me)
no flags Details | Diff | Splinter Review
Patch v2 (1.84 KB, patch)
2012-07-25 14:45 PDT, Jared Wein [:jaws] (please needinfo? me)
gavin.sharp: review+
Details | Diff | Splinter Review

Description Jim Jeffery not reading bug-mail 1/2/11 2012-07-25 12:23:51 PDT
Tested using the hourly build based on cset:
https://hg.mozilla.org/mozilla-central/rev/75d16b99e8ab

Click on the 'Firefox button'
Note that in the right-column that 'Options' is missing from the list.

Options still shows in the Menu list if you press ALT.  

need some help finding regression window but I'm suspecting 
https://bugzilla.mozilla.org/show_bug.cgi?id=764872
https://bugzilla.mozilla.org/show_bug.cgi?id=764869

since they are providing a way to hide social functionality, ended up maybe somehow hiding the entire 'Options Button'
Comment 1 Alice0775 White 2012-07-25 12:48:43 PDT
Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/be7d963dcc80
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120723220243
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/46bd216c417f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120723222542
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=be7d963dcc80&tochange=46bd216c417f
Comment 2 Jared Wein [:jaws] (please needinfo? me) 2012-07-25 14:09:15 PDT
Created attachment 645880 [details] [diff] [review]
Patch

Untested since I had to pull latest from the tree and am rebuilding now, but from discussions in #fx-team, this seems like what we should have done.
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-07-25 14:17:05 PDT
Comment on attachment 645880 [details] [diff] [review]
Patch

Shouldn't it be after the menuseparator?
Comment 4 Jared Wein [:jaws] (please needinfo? me) 2012-07-25 14:23:43 PDT
Yeah, I wasn't sure if it should be with the other toolbars. Maybe it should be in its own section with its own separator?
Comment 5 Jared Wein [:jaws] (please needinfo? me) 2012-07-25 14:45:51 PDT
Created attachment 645892 [details] [diff] [review]
Patch v2

Ok I tested this patch and it is also with the toolbar menuitems in the options popup.
Comment 6 Jared Wein [:jaws] (please needinfo? me) 2012-07-25 15:22:04 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/8696db732026
Comment 7 Ed Morley [:emorley] 2012-07-26 05:09:34 PDT
https://hg.mozilla.org/mozilla-central/rev/8696db732026
Comment 8 Jim Jeffery not reading bug-mail 1/2/11 2012-07-26 09:02:36 PDT
Tested using cset: https://hg.mozilla.org/mozilla-central/rev/20db7c6d82cc -
Comment 9 Ed Morley [:emorley] 2012-08-08 09:29:32 PDT
https://hg.mozilla.org/mozilla-central/rev/8b3b879bc63f
Comment 10 Jared Wein [:jaws] (please needinfo? me) 2012-08-08 10:20:54 PDT
The above cset (comment 9) does not apply for this bug. I think the commit message should have said bug 775463.

Note You need to log in before you can comment on or make changes to this bug.