Windows startup time increased

RESOLVED FIXED

Status

SeaMonkey
General
--
major
RESOLVED FIXED
17 years ago
13 years ago

People

(Reporter: Blake Ross, Assigned: Cathleen)

Tracking

({perf, regression, topperf})

Trunk
x86
Windows 2000
perf, regression, topperf
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nav+perf])

(Reporter)

Description

17 years ago
Paul's startup testing shows a consistent ~1/2 sec. increase (from the last 
stable time of ~19) in Windows startup time beginning around 4/18.  In general, 
these tests seem a little fluky; numbers of have hit 20 and 21 before in the 
past, but since they've hovered in 21.xx sec. for a week now, I think it's time 
to take a look.  See results in n.p.m.perf.
(Reporter)

Comment 1

17 years ago
Er, to clarify, that's "1 or 2" seconds.  Not half a second.  Need to find an 
owner for this...
(Assignee)

Comment 2

17 years ago
taking the bug for now.
investigating startup improvement in conjuction with bug 76705
Assignee: asa → cathleen
PSM2?

/be
(Reporter)

Updated

17 years ago
Keywords: mozilla0.9.1, perf, regression
(Assignee)

Comment 4

17 years ago
PSM2 bug 75947 is on our list of starup improvements bugs.  this is definitely
one aspect that's affecting starup timing, ever since it becomes part of client
build.
(Reporter)

Comment 5

17 years ago
Windows startup times are now--for the second day in a row-- over 22 seconds 
(to surpass 6.01 startup :-/).  That's up about 3 seconds from what 
the 'average' time was.  Anyone looking into this?
Keywords: nsbeta1, topperf
(Assignee)

Updated

17 years ago
Blocks: 7251
Depends on: 75947
(Reporter)

Updated

17 years ago
Whiteboard: [nav+perf]

Updated

17 years ago
No longer blocks: 7251

Updated

17 years ago
Blocks: 7251

Updated

16 years ago
Blocks: 104166

Comment 6

16 years ago
current status?
(Assignee)

Comment 7

16 years ago
this increase was due to PSM landing in mozilla tree.  See bug 75947, it's
fixed, and improved 5% on startup.

marking FIXED.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.