Last Comment Bug 777618 - Kill VALUE_TO_BOOLEAN in interpreter
: Kill VALUE_TO_BOOLEAN in interpreter
Status: RESOLVED FIXED
[js:t]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla17
Assigned To: Eric Faust [:efaust]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 21:37 PDT by Eric Faust [:efaust]
Modified: 2012-07-27 08:59 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (3.56 KB, patch)
2012-07-25 21:37 PDT, Eric Faust [:efaust]
luke: review+
Details | Diff | Splinter Review

Description Eric Faust [:efaust] 2012-07-25 21:37:43 PDT
Created attachment 646018 [details] [diff] [review]
Patch

Bug 749536 renders VALUE_TO_BOOLEAN unnecessary. Kill it.
Comment 1 Luke Wagner [:luke] 2012-07-26 01:39:01 PDT
Comment on attachment 646018 [details] [diff] [review]
Patch

I would even not mind if you inlined POP_BOOLEAN (since it takes two lines (for the declaration) in the caller anyways).
Comment 3 :Ehsan Akhgari (away Aug 1-5) 2012-07-27 08:59:17 PDT
https://hg.mozilla.org/mozilla-central/rev/19a7e39d99f2

Note You need to log in before you can comment on or make changes to this bug.