The default bug view has changed. See this FAQ.

[AccessFu] Disable EBT in Firefox 16 for Jelly Bean

RESOLVED FIXED

Status

()

Core
Disability Access APIs
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: eeejay, Assigned: eeejay)

Tracking

16 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox16 fixed, firefox17 unaffected)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
The changes needed to be done to support JB are probably to disruptive. I propose blacklisting JB in this release, and having full support for the next release.
(Assignee)

Comment 1

5 years ago
s/to disruptive/too disruptive/
(Assignee)

Comment 2

5 years ago
Created attachment 646173 [details] [diff] [review]
Disable explore by touch for devices on API version 16 (Jelly Bean) and above.
(Assignee)

Updated

5 years ago
status-firefox16: --- → affected
(Assignee)

Updated

5 years ago
Attachment #646173 - Flags: review?(dbolter)
(Assignee)

Updated

5 years ago
Version: Trunk → 16 Branch

Updated

5 years ago
Attachment #646173 - Flags: review?(dbolter) → review+

Comment 3

5 years ago
Comment on attachment 646173 [details] [diff] [review]
Disable explore by touch for devices on API version 16 (Jelly Bean) and above.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Explore By Touch support added initially for Ice Cream Sandwich.
User impact if declined: People on Jelly Bean will get very inconsistent user experience, so it's better to turn this off for Aurora on Jelly Bean alltogether.
Testing completed (on m-c, etc.): No, this is supposed to only run on Aurora, Central will get full jelly Bean support of the Explore By Touch feature.
Risk to taking this patch (and alternatives if risky): None.
String or UUID changes made by this patch: None.
Attachment #646173 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Attachment #646173 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

5 years ago
tracking-firefox16: --- → +
(Assignee)

Comment 4

5 years ago
http://hg.mozilla.org/releases/mozilla-aurora/rev/712a7cdbdf7c
Assignee: nobody → eitan
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-firefox16: affected → fixed
tracking-firefox16: + → ---
Resolution: --- → FIXED

Comment 5

5 years ago
(In reply to Marco Zehe (:MarcoZ) from comment #3)
> Comment on attachment 646173 [details] [diff] [review]
> Disable explore by touch for devices on API version 16 (Jelly Bean) and
> above.
> 
> [Approval Request Comment]
> User impact if declined: People on Jelly Bean will get very inconsistent
> user experience, so it's better to turn this off for Aurora on Jelly Bean
> alltogether.

If this remains true for FF17 on Aurora, please file a new bug and nominate the patch for approval. Thanks!

Comment 6

5 years ago
It doesn't. 17 will have full Jelly Bean support and thus doesn't need the feature to be disabled. This particular bug should just ride the 16 train to release. :)

Comment 7

5 years ago
Adjusting summary to make it unambiguous and setting tracking flag for 17 to indicate that that version is unaffected.
status-firefox17: --- → unaffected
Summary: [AccessFu] Disable EBT in Aurora for Jelly Bean → [AccessFu] Disable EBT in Firefox 16 for Jelly Bean
You need to log in before you can comment on or make changes to this bug.