Last Comment Bug 777924 - Opening a popup window causes web page parts to be rendered in incorrect spots
: Opening a popup window causes web page parts to be rendered in incorrect spots
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla17
Assigned To: Matt Woodrow (:mattwoodrow)
:
Mentors:
Depends on: 961249
Blocks: dlbi
  Show dependency treegraph
 
Reported: 2012-07-26 14:15 PDT by :Ehsan Akhgari (busy, don't ask for review please)
Modified: 2014-01-17 14:31 PST (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Invalidate layers when transitioning out of flattening component alpha (1012 bytes, patch)
2012-07-26 17:41 PDT, Matt Woodrow (:mattwoodrow)
roc: review+
Details | Diff | Review

Description :Ehsan Akhgari (busy, don't ask for review please) 2012-07-26 14:15:27 PDT
STR:

1. Open https://bugzilla.mozilla.org/enter_bug.cgi?product=Core&component=Editor
2. Focus the CC field, and type in ":aryeh" without the quotes.
3. Wait shortly for the helper popup window to be open.  Parts of the web page would suddenly get drawn in different spots.

Alice, do you have access to a Linux machine which can reproduce this?  It would be great if you can find a regression range for us if you do!  :-)

Here's the gfx section of my about:support:

  Graphics

        Adapter Description
        Tungsten Graphics, Inc -- Mesa DRI Intel(R) Sandybridge Server

        Vendor ID
        Tungsten Graphics, Inc

        Device ID
        Mesa DRI Intel(R) Sandybridge Server

        Driver Version
        3.0 Mesa 8.0.2

        WebGL Renderer
        Tungsten Graphics, Inc -- Mesa DRI Intel(R) Sandybridge Server  -- 3.0 Mesa 8.0.2

        GPU Accelerated Windows
        0

        AzureBackend
        skia
Comment 1 Alice0775 White 2012-07-26 14:35:53 PDT
I can reproduce with HWA off.

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/82b6c5885345
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120722190243
Bad:
http://hg.mozilla.org/mozilla-central/rev/d78729026fb9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120723063342


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/9302468f64fa
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120722192842
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/a5ee3b2e133a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120722200242
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9302468f64fa&tochange=a5ee3b2e133a
Comment 2 :Ehsan Akhgari (busy, don't ask for review please) 2012-07-26 14:51:56 PDT
I'm gonna say that the three patches from bug 539356 regressed this!
Comment 3 Matt Woodrow (:mattwoodrow) 2012-07-26 17:24:11 PDT
I can't reproduce this, but I do get parts of the page drawn wrong if I reload after opening a popup.

Do you have any addons installed that might affect this?
Comment 4 :Ehsan Akhgari (busy, don't ask for review please) 2012-07-26 17:30:10 PDT
(In reply to comment #3)
> I can't reproduce this, but I do get parts of the page drawn wrong if I reload
> after opening a popup.
> 
> Do you have any addons installed that might affect this?

I have Bugzilla Tweaks and BugzillaJS installed, but they both simply modify the DOM.  It might help if you install them, but I don't believe they're at blame here.  Alice could reproduce as well.
Comment 5 Matt Woodrow (:mattwoodrow) 2012-07-26 17:41:48 PDT
Created attachment 646430 [details] [diff] [review]
Invalidate layers when transitioning out of flattening component alpha

With those addons I get incorrect drawing when the page loads, I don't even need to touch the popup.

This patch fixes all the issues I can find.
Comment 6 Matt Woodrow (:mattwoodrow) 2012-07-26 20:09:19 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/73d5c4461f12
Comment 7 :Ehsan Akhgari (busy, don't ask for review please) 2012-07-27 08:57:01 PDT
https://hg.mozilla.org/mozilla-central/rev/73d5c4461f12

Note You need to log in before you can comment on or make changes to this bug.