Last Comment Bug 777956 - With CPG, AutoCompartment no longer needs to store the target object
: With CPG, AutoCompartment no longer needs to store the target object
Status: RESOLVED FIXED
[js:t]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla17
Assigned To: Steve Fink [:sfink] [:s:] (PTO Sep23-28)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 15:15 PDT by Steve Fink [:sfink] [:s:] (PTO Sep23-28)
Modified: 2012-07-28 18:36 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
With CPG, AutoCompartment no longer needs to store the target object (7.65 KB, patch)
2012-07-26 15:16 PDT, Steve Fink [:sfink] [:s:] (PTO Sep23-28)
luke: review+
Details | Diff | Splinter Review

Description Steve Fink [:sfink] [:s:] (PTO Sep23-28) 2012-07-26 15:15:55 PDT
Happily, it also looks like removing that field may also drop us below an alignment threshold. Just in case you had a million AutoCompartments on the stack... (and I haven't pushed this to try yet, so I may be wrong anyway)

I also noticed that the global dummy_class for entering scripts' compartments is no longer used, so I nuked it.
Comment 1 Steve Fink [:sfink] [:s:] (PTO Sep23-28) 2012-07-26 15:16:03 PDT
Created attachment 646365 [details] [diff] [review]
With CPG, AutoCompartment no longer needs to store the target object
Comment 2 Luke Wagner [:luke] 2012-07-26 15:19:40 PDT
Comment on attachment 646365 [details] [diff] [review]
With CPG, AutoCompartment no longer needs to store the target object

Kill all the dummies!
Comment 3 Steve Fink [:sfink] [:s:] (PTO Sep23-28) 2012-07-27 13:21:47 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/efb7823db78a
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-07-28 18:36:40 PDT
https://hg.mozilla.org/mozilla-central/rev/efb7823db78a

Note You need to log in before you can comment on or make changes to this bug.