Last Comment Bug 778081 - java.lang.NullPointerException: at org.mozilla.gecko.sync.CommandProcessor$Command.getArgsList(CommandProcessor.java)
: java.lang.NullPointerException: at org.mozilla.gecko.sync.CommandProcessor$Co...
Status: RESOLVED FIXED
[native-crash][sync]
: crash
Product: Android Background Services
Classification: Client Software
Component: Android Sync (show other bugs)
: unspecified
: ARM Android
: P2 critical
: mozilla17
Assigned To: Nick Alexander :nalexander
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-27 02:48 PDT by Scoobidiver (away)
Modified: 2013-04-04 13:48 PDT (History)
2 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
Proposed patch for Aurora. v1 (4.75 KB, patch)
2012-07-30 13:32 PDT, Richard Newman [:rnewman]
rnewman: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Scoobidiver (away) 2012-07-27 02:48:47 PDT
There's one crash in 16.0a2/20120726: bp-66a39aa8-1e80-42e1-bfb7-9af262120726.

java.lang.NullPointerException
	at org.mozilla.gecko.sync.CommandProcessor$Command.getArgsList(CommandProcessor.java:72)
	at org.mozilla.gecko.sync.CommandProcessor.sendCommand(CommandProcessor.java:191)
	at org.mozilla.gecko.sync.CommandProcessor.sendURIToClientForDisplay(CommandProcessor.java:163)
	at org.mozilla.gecko.sync.setup.activities.SendTabActivity$3.run(SendTabActivity.java:137)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A+at+org.mozilla.gecko.sync.CommandProcessor%24Command.getArgsList%28CommandProcessor.java%29
Comment 1 Scoobidiver (away) 2012-07-27 06:09:39 PDT
and now two crashes in 17.0a1/20120726.
It might be a regression from bug 774233.
Comment 2 Richard Newman [:rnewman] 2012-07-27 11:39:14 PDT
Looks like this can only happen when getJSONArrayFromCursor returns null. The other call sites don't result in a null `args` array inside `Command`.

No chance of this being a regression from that bug. It's just dependent on input data.
Comment 3 Nick Alexander :nalexander 2012-07-30 13:08:18 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/6b7ed8e5d616
Comment 4 Richard Newman [:rnewman] 2012-07-30 13:32:53 PDT
Created attachment 647278 [details] [diff] [review]
Proposed patch for Aurora. v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #):
  Since original landing of command send code.
 
User impact if declined: 
  Low rate of crashes.

Testing completed (on m-c, etc.): 
  Landed on m-i now; not really QA-able, but we'll see if anything bad happens.

Risk to taking this patch (and alternatives if risky): 
  Minimal.

String or UUID changes made by this patch: 
  I stripped out the string change made in the m-i landing, so this is code only.
Comment 5 Ed Morley [:emorley] 2012-07-31 06:12:30 PDT
https://hg.mozilla.org/mozilla-central/rev/6b7ed8e5d616
Comment 6 Lukas Blakk [:lsblakk] use ?needinfo 2012-07-31 15:41:03 PDT
Comment on attachment 647278 [details] [diff] [review]
Proposed patch for Aurora. v1

No strings, no problems. Approving.
Comment 7 Richard Newman [:rnewman] 2012-07-31 18:50:03 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/cbf944c8b6fc

Note You need to log in before you can comment on or make changes to this bug.