Intermittent browser_privatebrowsing_cookieacceptdialog.js | an unexpected uncaught JS exception reported through window.onerror - NS_ERROR_FAILURE: Failure at chrome://browser/content/browser.js:6369

RESOLVED DUPLICATE of bug 780594

Status

()

Firefox
Private Browsing
RESOLVED DUPLICATE of bug 780594
6 years ago
6 years ago

People

(Reporter: emorley, Unassigned)

Tracking

Trunk
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Rev4 MacOSX Snow Leopard 10.6 mozilla-inbound opt test mochitest-other on 2012-07-26 16:29:01 PDT for push d61eadd4c511

slave: talos-r4-snow-070

https://tbpl.mozilla.org/php/getParsedLog.php?id=13889102&tree=Mozilla-Inbound

{
TEST-START | chrome://mochitests/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_cookieacceptdialog.js
TEST-PASS | chrome://mochitests/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_cookieacceptdialog.js | The remember checkbox should exist
TEST-PASS | chrome://mochitests/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_cookieacceptdialog.js | The checkbox should not be disabled
TEST-PASS | chrome://mochitests/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_cookieacceptdialog.js | The remember checkbox should exist
TEST-PASS | chrome://mochitests/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_cookieacceptdialog.js | The checkbox should be disabled
TEST-PASS | chrome://mochitests/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_cookieacceptdialog.js | The remember checkbox should exist
TEST-PASS | chrome://mochitests/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_cookieacceptdialog.js | The checkbox should not be disabled
TEST-PASS | chrome://mochitests/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_cookieacceptdialog.js | Private browsing should be terminated after finishing the test
INFO TEST-END | chrome://mochitests/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_cookieacceptdialog.js | finished in 1781ms
TEST-INFO | checking window state
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_cookieacceptdialog.js | an unexpected uncaught JS exception reported through window.onerror - NS_ERROR_FAILURE: Failure at chrome://browser/content/browser.js:6309
Stack trace:
    JS frame :: chrome://mochikit/content/tests/SimpleTest/SimpleTest.js :: simpletestOnerror :: line 994
    native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
    native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
}
Comment hidden (Treeherder Robot)
(Reporter)

Updated

6 years ago
Summary: Intermittent browser_privatebrowsing_cookieacceptdialog.js | an unexpected uncaught JS exception reported through window.onerror - NS_ERROR_FAILURE: Failure at chrome://browser/content/browser.js:6309 → Intermittent browser_privatebrowsing_cookieacceptdialog.js | an unexpected uncaught JS exception reported through window.onerror - NS_ERROR_FAILURE: Failure at chrome://browser/content/browser.js:6369
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 33

6 years ago
Ehsan, do you have any ideas about this top orange?
I downloaded one of the affected builds and looked at the failing line:

>/**
>* We can avoid adding multiple load event listeners and save some time by adding
>* one listener that calls all real handlers.
>*/
>function pageShowEventHandlers(event) {
>  // Filter out events that are not about the document load we are interested in
>  if (event.target == content.document) {
>    charsetLoadListener(event);
>    XULBrowserWindow.asyncUpdateUI();
>
>    // The PluginClickToPlay events are not fired when navigating using the
>    // BF cache. |event.persisted| is true when the page is loaded from the
>    // BF cache, so this code reshows the notification if necessary.
>    if (event.persisted)
>      gPluginHandler.reshowClickToPlayNotification();
>  }
>}

The |if (event.target == content.document)| check is causing something to throw for some reason.

Judging by WOO, http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=8%2F11%2F2012&enddate=8%2F14%2F2012 should cover the range in which this could have been introduced. Maybe we could go back as far as the 10th, but that feels unlikely to me.
How convenient that there's a bug in that range that specifically changed the pageshowEventHandlers method.
Blocks: 782375
(Reporter)

Comment 36

6 years ago
(In reply to Josh Matthews [:jdm] from comment #34)
> I downloaded one of the affected builds and looked at the failing line:

(In reply to Josh Matthews [:jdm] from comment #35)
> How convenient that there's a bug in that range that specifically changed
> the pageshowEventHandlers method.

Thank you for taking a look at this! :-D

Updated

6 years ago
No longer blocks: 438871, 782375
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 780594
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.