The default bug view has changed. See this FAQ.

JavaScript Error: "Error selecting word: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsISelectionController.wordMove]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://b

VERIFIED FIXED in Firefox 15

Status

()

Firefox for Android
Text Selection
VERIFIED FIXED
5 years ago
3 years ago

People

(Reporter: aaronmt, Assigned: Margaret)

Tracking

Trunk
Firefox 17
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox15 fixed, firefox16 fixed, firefox17 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
E/GeckoConsole(10402): [JavaScript Error: "Error selecting word: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsISelectionController.wordMove]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://browser/content/browser.js :: sh_startSelection :: line 1666"  data: no]" {file: "chrome://browser/content/browser.js" line: 1672}]
(Reporter)

Comment 1

5 years ago
I've seen this one in my log before when using text-selection on pages. You can reproduce this by long-tap holding in content on about:logo.
(Assignee)

Comment 2

5 years ago
Hm, this is an error we're catching ourselves, so it shouldn't lead to other failures, but I can look into why this is happening.

Also, I just noticed that we don't properly clean up after ourselves if we bail in startSelection. We should fix that.
(Assignee)

Comment 3

5 years ago
Created attachment 649712 [details] [diff] [review]
patch

Logging this error is pretty useless, but we should make sure we clean up after ourselves if we're bailing in startSelection. This patch takes care of that.
Assignee: nobody → margaret.leibovic
Attachment #649712 - Flags: review?(mark.finkle)
Attachment #649712 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/7047de4a90f2
Target Milestone: --- → Firefox 17
https://hg.mozilla.org/mozilla-central/rev/7047de4a90f2
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
status-firefox17: affected → ---
(Reporter)

Comment 6

5 years ago
Channel nomination?
Status: RESOLVED → VERIFIED
status-firefox17: --- → verified
(Assignee)

Comment 7

5 years ago
Comment on attachment 649712 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 695173 (text selection)
User impact if declined: logging a useless error isn't really a big deal, but without cleaning up properly, we can fail to remove the pagehide listener, which may cause issues
Testing completed (on m-c, etc.): landed on m-c 8/8
Risk to taking this patch (and alternatives if risky): low-risk, adds code to clean up state of SelectionHandler when we fail to start a selection
String or UUID changes made by this patch: n/a
Attachment #649712 - Flags: approval-mozilla-beta?
Attachment #649712 - Flags: approval-mozilla-aurora?
Comment on attachment 649712 [details] [diff] [review]
patch

Small patch, low risk, wouldn't normally be a candidate for uplift but it's good to clean up the unused errors so approving for branches.
Attachment #649712 - Flags: approval-mozilla-beta?
Attachment #649712 - Flags: approval-mozilla-beta+
Attachment #649712 - Flags: approval-mozilla-aurora?
Attachment #649712 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 9

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/824121cfc9ad
https://hg.mozilla.org/releases/mozilla-beta/rev/beb43bf67781
status-firefox15: affected → fixed
status-firefox16: affected → fixed
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.