Last Comment Bug 778301 - Remove old change for llvm.org/pr11003
: Remove old change for llvm.org/pr11003
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla17
Assigned To: Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-27 14:14 PDT by Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
Modified: 2012-07-29 15:27 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
remove it (1.02 KB, patch)
2012-07-27 14:14 PDT, Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
luke: review+
Details | Diff | Splinter Review

Description Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-07-27 14:14:09 PDT
Created attachment 646717 [details] [diff] [review]
remove it
Comment 1 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-07-27 14:19:38 PDT
Comment on attachment 646717 [details] [diff] [review]
remove it

I am testing and benchmarking it, but I think review can go in parallel.
Comment 2 :Ehsan Akhgari 2012-07-27 14:29:38 PDT
Which clang version was this fixed in?  I have another piece of code in Gecko which used to hit an LLVM bug which has since been fixed.  I wonder what our policy for keeping the code buildable with older clang versions should be...
Comment 3 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-07-27 14:51:23 PDT
It was fixed in r141137, from Oct 4, 2011. The fix in included clang 3.0 and 3.1. It is also in apple's xcode 4.4 (not sure about older versions).

I think on OS X we can build with clang >= 3.0, but I am not sure.
Comment 4 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-07-28 05:03:49 PDT
The talos runs are fine:

http://bit.ly/MRVkoD

I will check it in.
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-07-29 15:27:43 PDT
https://hg.mozilla.org/mozilla-central/rev/0dbf799a2371

Note You need to log in before you can comment on or make changes to this bug.